Bug 880031 - [ALL_LANG][SAM CLI] Unlocalized strings for user module
[ALL_LANG][SAM CLI] Unlocalized strings for user module
Status: CLOSED NEXTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
medium Severity medium
: rc
: 2.0
Assigned To: Adam Price
SAM QE List
: Translation, Triaged
: 887072 (view as bug list)
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-25 22:37 EST by Lijun Li
Modified: 2013-06-07 14:27 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 14:27:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2012-11-25 22:37:48 EST
Description of problem:
Unlocalized strings for user module

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
# headpin -u admin -p admin user create --username=te --password=red --email=te@localhost
Validation failed: Username must contain at least 3 character, 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
Password 5 文字以上である必要があります。

# headpin -u admin -p admin user create --username=test --password=redhat --email=test@localhost --disabled=true  --default_locale=en
Validation failed: Username has already been taken
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin user info --username=
Could not find user ''
^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin user info --username=admin
--------------------------------------------------------------------------------------------------
                                           ユーザー情報
--------------------------------------------------------------------------------------------------

Id                   : 1
Username             : admin
Email                : root@localhost
Disabled             : False
Default Organization : None
Default Environment  : None
Default Locale       : es
^^^^^^^^^Unlocalized

# headpin -u admin -p admin user list
--------------------------------------------------------------------------------------------------
                                          ユーザーの一覧

Id Username      Email              Disabled Default Organization Default Environment 
^^^^^^^^^Unlocalized
--------------------------------------------------------------------------------------------------
3  en_US         en_US@localhost    False    None                 None                
12 es_ES         es_ES@localhost    False    None                 None     



# headpin -u admin -p admin user list_roles --username=admin
--------------------------------------------------------------------------------------------------
                                        ユーザーロール一覧

Id Name 
^^^^^Unlocalized         
--------------------------------------------------------------------------------------------------
1  Administrator           



# headpin -u admin -p admin user sync_ldap_roles
Server localhost refused connection on port 389.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized


# headpin -u admin -p admin user assign_role --username=test --role=Administrator
User 'test' assigned to role 'Administrator'
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin user assign_role --username=test --role=Administrator
Validation failed: User id can only have one same role assigned
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin user assign_role --username=test --role=test
Role [ test ] not found
^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin user unassign_role --username=test --role=Administrator
User 'test' unassigned from role 'Administrator'
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin user update --username=test --password=
Validation failed: Password 5 文字以上である必要があります。
^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin user update --username=test --password=redhat --email=test@localhost --disabled=false --default_organization=test --default_environment=test --no_default_environment=t
Usage:  headpin <options> user update <options>

headpin: error: --no_default_environment option does not take a value
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized


# headpin -u admin -p admin user update --username=test --password=redhat --email=test@localhost --disabled=false --default_organization=test --default_environment=test --default_locale=t
Validation failed: Default locale must be one of de, en, es, fr, it, ja, ko, 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
pt-BR, gu, hi, mr, or, ru, te, pa, kn, bn, ta, zh-CN, zh-TW


Actual results:
Unlocalized strings for user module

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Adam Price 2012-12-11 14:44:45 EST
Most column names are not localized. I will add them to localization, but it depends on if the translators get to them in time.

Most error messages that were coming from the server were being sent as English, so the CLI has no control over that. We are actively working on getting the error messages and validation error messages translated.
Comment 2 Noriko Mizumoto 2012-12-13 03:17:04 EST
confirmed for ja-JP
Comment 3 Sam Friedmann 2012-12-13 20:29:07 EST
Some unlocalized strings in fr-FR too.
Comment 4 Hedda Peters 2012-12-13 22:31:03 EST
Confirmed for de-DE, too, also the usual "Usage", "Supported Commands", "Options", "show this help message and exit", e.g.: 


[root@i18nsamtest ~]# headpin user -h
Usage:  headpin <options> user <command>
Supported Commands:
	assign_role    Rolle zu Benutzer zuweisen
	create         Benutzer erstellen
	delete         Benutzer löschen
	info           Informationen über Benutzer anzeigen
	list           Alle bekannten Benutzer auflisten
	list_roles     Rollen des Benutzers auflisten
	report         Benutzerbericht
	sync_ldap_roles Rollen mit LDAP-Gruppen synchronisieren 
	unassign_role  Rolle von Benutzer entfernen
	update         Benutzer aktualisieren

Options:
  -h, --help  show this help message and exit
Comment 5 Eunju, Kim 2012-12-13 22:35:30 EST
confirmed for ko-KR.
Comment 6 Lijun Li 2012-12-13 22:36:39 EST
*** Bug 887072 has been marked as a duplicate of this bug. ***
Comment 7 Tom McKay 2012-12-18 09:12:08 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 9 Bryan Kearney 2013-06-07 14:19:45 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 10 Bryan Kearney 2013-06-07 14:27:59 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.

Note You need to log in before you can comment on or make changes to this bug.