Bug 887072 - Test case failure: SAM CLI: user
Test case failure: SAM CLI: user
Status: CLOSED DUPLICATE of bug 880031
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 20:36 EST by Angela Garcia
Modified: 2012-12-13 22:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Not all messages are localized Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 22:36:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Angela Garcia 2012-12-13 20:36:28 EST
Not all messages are localized

Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
SAM-20121130.n.0

Steps to Reproduce: 
set --default_locale=xx for your test language locale.


# headpin user -h

  * Create

# headpin user create -h

# headpin -u admin -p admin user create --username=te --password=red --email=
te@localhost
Validation failed: Username must contain at least 3 character, Password must be
at least 5 characters.


# headpin -u admin -p admin user create --username=test --password=redhat
--email=test@localhost --disabled=true  --default_locale=en

Successfully created user [ test ]
# headpin -u admin -p admin user create --username=test --password=redhat
--email=test@localhost --disabled=false  --default_locale=en
Validation failed: Username has already been taken

# headpin -u admin -p admin user create --username=test --password=redhat
--email=test@localhost --disabled=t --default_organization=test
--default_environment=test --default_locale=en
Usage:  headpin <options> user create <options>

headpin: error: option --disabled: invalid boolean value: 't'

# headpin -u admin -p admin user create --username=test --password=redhat
--email=test@localhost --disabled=true --default_organization=test
--default_environment=test --default_locale=en
Successfully created user [ test ]

# headpin -u admin -p admin user create --username=test --password=redhat
--email=test@localhost --disabled=true --default_organization=test
--default_environment=test --default_locale=en -g -v -d DELIMITER --noheading
Successfully created user [ test ]

  * Info

# headpin user info -h

# headpin -u admin -p admin user info --username=
Could not find user ''

# headpin -u admin -p admin user info --username=admin

# headpin -u admin -p admin user info --username=test

# headpin -u admin -p admin user info --username=test -g

# headpin -u admin -p admin user info --username=test -v

# headpin -u admin -p admin user info --username=test --noheading

# headpin -u admin -p admin user info --username=test -g -v -d DELIMITER
--noheading

  * List

# headpin user list -h

# headpin -u admin -p admin user list

# headpin -u admin -p admin user list -g

# headpin -u admin -p admin user list -v

# headpin -u admin -p admin user list --noheading

# headpin -u admin -p admin user list  -g -v -d DELIMITER --noheading

  * List_roles

# headpin user list_roles -h

# headpin -u admin -p admin user list_roles --username=admin

# headpin -u admin -p admin user list_roles --username=test

# headpin -u admin -p admin user list_roles --username=test -g

# headpin -u admin -p admin user list_roles --username=test -v

# headpin -u admin -p admin user list_roles --username=test --noheading

# headpin -u admin -p admin user list_roles --username=test -g -v -d DELIMITER
--noheading

  * Report

# headpin user report -h

# headpin -u admin -p admin user report

# headpin -u admin -p admin user report --format=html

# headpin -u admin -p admin user report --format=text

# headpin -u admin -p admin user report --format=csv

# headpin -u admin -p admin user report --format=pdf

# ls

katello_users_report.pdf (Open/check the pdf file)

# headpin -u admin -p admin user report  -g -v -d DELIMITER --noheading

  * sync_ldap_roles

# headpin user sync_ldap_roles -h

# headpin -u admin -p admin user sync_ldap_roles
Server localhost refused connection on port 389.

  * assign_role

# headpin user assign_role -h

# headpin -u admin -p admin user assign_role --username=test --role=
Administrator
User 'test' assigned to role 'Administrator'

# headpin -u admin -p admin user assign_role --username=test --role=
Administrator
Validation failed: User id can only have one same role assigned

(wrong role name)
# headpin -u admin -p admin user assign_role --username=test --role=test
Role [ test ] not found

  * unassign_role

# headpin user unassign_role -h

# headpin -u admin -p admin user unassign_role -
Usage:  headpin <options> user unassign_role <options>

headpin: errors:
1) Option --username is required; please see --help
2) Option --role is required; please see --help

 headpin -u admin -p admin user unassign_role --username=test --role=
Administrator
User 'test' unassigned from role 'Administrator'

# headpin -u admin -p admin user unassign_role --username=test --role=
Administrator
Validation failed: Cannot dissociate user 'test' from 'Administrator' role.
Need at least one user in the 'Administrator' role.

  * Update

# headpin user update -h

# headpin user update --
Usage:  headpin <options> user update <options>

headpin: errors:
1) Option --username is required; please see --help
2) At least one of --password, --email, --disabled, --default_organization,
--default_environment, --no_default_environment, --default_locale is required;
please see --help

# headpin -u admin -p admin user update --username=test --password=
Validation failed: Password must be at least 5 characters.

# headpin -u admin -p admin user update --username=test --password=redhat
--email=test@localhost --disabled=false --default_organization=test
--default_environment=test --no_default_environment=t
Usage:  headpin <options> user update <options>

headpin: error: --no_default_environment option does not take a value

# headpin -u admin -p admin user update --username=test --password=redhat
--email=test@localhost --disabled=false --default_organization=test
--default_environment=test --default_locale=t
Validation failed: Default locale must be one of de, en, es, fr, it, ja, ko,
pt-BR, gu, hi, mr, or, ru, te, pa, kn, bn, ta, zh-CN, zh-TW

# headpin -u admin -p admin user update --username=test --password=redhat
--email=test@localhost --disabled=false --default_organization=test
--default_environment=test --default_locale=en
Successfully updated user [ test ]

  * Delete

# headpin user delete -h

# headpin -u admin -p admin user delete --username=test
Successfully deleted user [ test ]

 

 



Actual results: 
#FIXME

Expected results:
Messages are localized.
Comment 1 Lijun Li 2012-12-13 22:36:39 EST

*** This bug has been marked as a duplicate of bug 880031 ***

Note You need to log in before you can comment on or make changes to this bug.