Bug 880048 - [ALL_LANG][SAM CLI] Unlocalized strings for user_role module
[ALL_LANG][SAM CLI] Unlocalized strings for user_role module
Status: CLOSED NEXTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
medium Severity medium
: rc
: 2.0
Assigned To: Adam Price
SAM QE List
: Translation, Triaged
: 887073 (view as bug list)
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-26 00:47 EST by Lijun Li
Modified: 2013-06-07 14:28 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 14:28:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2012-11-26 00:47:45 EST
Description of problem:
Unlocalized strings for user_role module

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
# headpin -u admin -p admin user_role create --name=
Validation failed: Name must contain at least 1 character, Name can't be blank
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin user_role create --name=test --description=test
Validation failed: Name has already been taken
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized  

# headpin -u admin -p admin user_role info --name=test --permission_details
--------------------------------------------------------------------------------------------------
                                        ユーザーロール情報
--------------------------------------------------------------------------------------------------

Id          : 34
Name        : test
Description : test
Permissions:
    あい
    	for: roles
    	verbs: create
    	on: 
Ldap Groups : 
^^^^^^^^^Unlocalized

# headpin -u admin -p admin user_role list
--------------------------------------------------------------------------------------------------
                                        ユーザーロール一覧

Id Name   
^^^^^^Unlocalized         
--------------------------------------------------------------------------------------------------
1  Administrator   


# headpin -u admin -p admin user_role add_ldap_group --name=test --group_name=test
Server localhost refused connection on port 389.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

headpin -u admin -p admin user_role add_ldap_group --name=test --group_name=test
Validation failed: Ldap group has already been taken
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin user_role remove_ldap_group --name=wrong_name --group_name=
Cannot find user role 'wrong_name'
^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin user_role remove_ldap_group --name=test --group_name=wrong_name
LDAP group 'wrong_name' associated to role 'test' was not found.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin user_role update --name=test --new_name=
Validation failed: Name must contain at least 1 character, Name can't be blank
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized



Actual results:
Unlocalized strings for user_role module

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Adam Price 2012-12-11 14:44:49 EST
Most column names are not localized. I will add them to localization, but it depends on if the translators get to them in time.

Most error messages that were coming from the server were being sent as English, so the CLI has no control over that. We are actively working on getting the error messages and validation error messages translated.
Comment 2 Noriko Mizumoto 2012-12-13 19:47:36 EST
confirmed for ja-JP
Comment 3 Hedda Peters 2012-12-13 22:37:23 EST
confirmed for de-DE
Comment 4 Lijun Li 2012-12-13 22:37:42 EST
*** Bug 887073 has been marked as a duplicate of this bug. ***
Comment 5 Sam Friedmann 2012-12-13 22:46:22 EST
Confirmed for fr-FR.
Comment 6 Eunju, Kim 2012-12-13 23:14:16 EST
not all of them half of them got same outcome for ko-KR.
Comment 7 Tom McKay 2012-12-18 09:12:15 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 9 Bryan Kearney 2013-06-07 14:19:54 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 10 Bryan Kearney 2013-06-07 14:28:14 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.

Note You need to log in before you can comment on or make changes to this bug.