Bug 887073 - Test case failure: SAM CLI: user_role
Test case failure: SAM CLI: user_role
Status: CLOSED DUPLICATE of bug 880048
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 20:38 EST by Angela Garcia
Modified: 2012-12-13 22:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Not all messages are localized. Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 22:37:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Angela Garcia 2012-12-13 20:38:46 EST
Not all messages are localized.

Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
SAM-20121130.n.0

Steps to Reproduce: 

# headpin user_role -h

  * Create

# headpin user_role create -h

# headpin -u admin -p admin user_role create --name=
Validation failed: Name must contain at least 2 characters, Name can't be blank

# headpin -u admin -p admin user_role create --name=test --description=test
Successfully created user role [ test ]

# headpin -u admin -p admin user_role create --name=test --description=test
Validation failed: Name has already been taken

  * Info

# headpin user_role info -h

# headpin -u admin -p admin user_role info --name=test

# headpin -u admin -p admin user_role info --name=test --permission_details

> add permission for the role

# headpin -u admin -p admin user_role info --name=test --permission_details

# headpin -u admin -p admin user_role info --name=test --permission_details -g

# headpin -u admin -p admin user_role info --name=test --permission_details -v

# headpin -u admin -p admin user_role info --name=test --permission_details
--noheading

# headpin -u admin -p admin user_role info --name=test --permission_details -g
-v -d DELIMITER --noheading

  * List

# headpin user_role list -h

# headpin -u admin -p admin user_role list

# headpin -u admin -p admin user_role list -g

# headpin -u admin -p admin user_role list -v

# headpin -u admin -p admin user_role list --noheading

# headpin -u admin -p admin user_role list  -g -v -d DELIMITER --noheading

  * add_ldap_group

# headpin user_role add_ldap_group -h

# headpin -u admin -p admin user_role add_ldap_group --name=test --group_name=
test
Server localhost refused connection on port 389.

# headpin -u admin -p admin user_role add_ldap_group --name=test --group_name=
test
Validation failed: Ldap group has already been taken

  * remove_ldap_group

# headpin user_role remove_ldap_group -h

# headpin -u admin -p admin user_role remove_ldap_group --name=wrong_name
--group_name=
Cannot find user role 'wrong_name'

# headpin -u admin -p admin user_role remove_ldap_group --name=test
--group_name=
Resource not found on the server

# headpin -u admin -p admin user_role remove_ldap_group --name=test
--group_name=wrong_name
LDAP group 'wrong_name' associated to role 'test' was not found.

# headpin -u admin -p admin user_role remove_ldap_group --name=test
--group_name=test
Successfully removed LDAP group [ test ] from the user role [ test ]

  * Update

# headpin user_role update -h

# headpin -u admin -p admin user_role update --name=test --new_name=
Validation failed: Name must contain at least 2 characters, Name can't be blank

# headpin -u admin -p admin user_role update --name=test --new_name=test
--description=test
Successfully updated user role [ test ]

  * Delete

# headpin user_role delete -h

# headpin -u admin -p admin user_role delete --name=test
Successfully deleted user role [ test ]

 

 

 



Actual results: 
#FIXME

Expected results:
Messages are localized.
Comment 1 Lijun Li 2012-12-13 22:37:42 EST

*** This bug has been marked as a duplicate of bug 880048 ***

Note You need to log in before you can comment on or make changes to this bug.