Bug 880066 - [ALL_LANG][SAM CLI] Unlocalized strings for org module.
[ALL_LANG][SAM CLI] Unlocalized strings for org module.
Status: CLOSED NEXTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
medium Severity medium
: rc
: 2.0
Assigned To: Adam Price
SAM QE List
: Translation, Triaged
: 887075 (view as bug list)
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-26 02:15 EST by Lijun Li
Modified: 2013-06-07 14:29 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 14:29:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2012-11-26 02:15:10 EST
Description of problem:
Unlocalized strings for org module

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
# headpin org -h
Usage:  headpin <options> org <command>
Supported Commands:
	add_default_system_info add default custom info keynames for systems
                                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
	apply_default_system_info apply default custom info keynames to all existing systems
                                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
	create         組織を作成
	delete         組織を削除
	info           組織に関する情報を一覧表示
	list           既知の組織の全一覧を表示
	remove_default_system_info remove default custom info keynames for systems
                                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
	subscriptions  サブスクリプションの表示
	update         組織を更新

Options:
  -h, --help  show this help message and exit

# headpin org add_default_system_info -h
Usage:  headpin <options> org add_default_system_info <options>

Options:
  -h, --help         show this help message and exit
  --name=NAME        組織名、例: foo.example.com (必須)
  --keyname=KEYNAME  name of the default custom info
                     ^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin org add_default_system_info --name=ACME_Corporation --keyname=test
Successfully added default custom info key [ test ] to Org [ ACME_Corporation ]
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin org create -h
Usage:  headpin <options> org create <options>

Options:
  -h, --help            show this help message and exit
  --name=NAME           organization name eg: ACME Corporation (required)
  --label=LABEL         organization label, ASCII identifier for the
                        Organization with no spaces eg: ACME_Corporation (will
                        be generated if not specified)
                        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
# headpin -u admin -p admin org create --name=
Validation failed: Label can't be blank, Label cannot contain characters other than ascii alpha numerals, '_', '-'. , Label must contain at least 1 character, Label can't be blank, Name must contain at least 1 character, Name can't be blank
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin org create --name=test
Validation failed: Name has already been taken, Label has already been taken
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin org create --name=testqd --label=??
Validation failed: Label is invalid, Label cannot contain characters other than ascii alpha numerals, '_', '-'. 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin org info --name=test
-------------------------------------------------------------------------------------
                                      組織情報
-------------------------------------------------------------------------------------

Id                       : 18
Name                     : test
Description:
^^^^^^Unlocalized
    None
利用可能なサービスレベル:
    
Default System Info Keys:
^^^^^^Unlocalized
    [  ]

# headpin -u admin -p admin org list
-------------------------------------------------------------------------------------
                                     組織の一覧

Id Name             Label                                Description   
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized                
-------------------------------------------------------------------------------------

# headpin -u admin -p admin org subscriptions --name=ACME_Corporation
-------------------------------------------------------------------------------------
                              組織のサブスクリプション
-------------------------------------------------------------------------------------

Subscription   : Red Hat Employee Subscription
Consumed       : 0
ContractNumber : 2596950
Sla            : 
Id             : 8ac28a8e3b273ec5013b2796ab650011
StartDate      : 2011/10/08 04:00:00
EndDate        : 2022/01/01 04:59:59


Subscription   : Red Hat Employee Subscription
Consumed       : 1
ContractNumber : 2596950
Sla            : 
Id             : 8ac28a8e3b039b3d013b1cc6345d0393
StartDate      : 2011/10/08 04:00:00
EndDate        : 2022/01/01 04:59:59
^^^^^^^^^^^^^^^^^Unlocalized


# headpin -u admin -p admin org apply_default_system_info --name=test
No default custom info keys to apply in Org [ test ]
^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin org apply_default_system_info --name=ACME_Corporation
Successfully applied default custom info keys to [ 1 ] systems in Org [ ACME_Corporation ]
^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin org remove_default_system_info --name=ACME_Corporation --keyname=test
Successfully removed default custom info key [ test ] for Org [ ACME_Corporation ]
^^^^^^^^^^^^^^^^^Unlocalized

Actual results:
Unlocalized strings for org module

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Adam Price 2012-12-11 14:44:58 EST
Most column names are not localized. I will add them to localization, but it depends on if the translators get to them in time.

Most error messages that were coming from the server were being sent as English, so the CLI has no control over that. We are actively working on getting the error messages and validation error messages translated.
Comment 2 Noriko Mizumoto 2012-12-13 20:00:17 EST
confirmed for ja-JP
Comment 3 Lijun Li 2012-12-13 22:38:34 EST
*** Bug 887075 has been marked as a duplicate of this bug. ***
Comment 4 Sam Friedmann 2012-12-13 22:49:40 EST
Confirmed for fr-FR.
Comment 5 Hedda Peters 2012-12-13 23:20:55 EST
confirmed for de-DE
Comment 6 Eunju, Kim 2012-12-13 23:29:23 EST
confirmed for ko-KR
Comment 7 Tom McKay 2012-12-18 09:12:27 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 9 Bryan Kearney 2013-06-07 14:20:38 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 10 Bryan Kearney 2013-06-07 14:29:07 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.

Note You need to log in before you can comment on or make changes to this bug.