Bug 887075 - Test case failure: SAM CLI: org
Test case failure: SAM CLI: org
Status: CLOSED DUPLICATE of bug 880066
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 20:46 EST by Angela Garcia
Modified: 2012-12-13 22:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Not all messages are localized Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 22:38:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Angela Garcia 2012-12-13 20:46:04 EST
Not all messages are localized

Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
SAM-20121130.n.0

Steps to Reproduce: 

# headpin org -h

  * Create

# headpin org create -h

# headpin -u admin -p admin org create --name=
Validation failed: Label can't be blank, Label cannot contain characters other
than ascii alpha numerals, '_', '-'. , Label must contain at least 2
characters, Label can't be blank, Name must contain at least 2 characters, Name
can't be blank

# headpin -u admin -p admin org create --name=test
Validation failed: Name has already been taken, Label has already been taken

# headpin -u admin -p admin org create --name=testqa
Successfully created org [ testqa ]

# headpin -u admin -p admin org create --name=testqd --label=??
Validation failed: Label is invalid, Label cannot contain characters other than
ascii alpha numerals, '_', '-'.

# headpin -u admin -p admin org create --name=testqc --label=testqc
--description=??
Successfully created org [ testqc ]

  * Info

# headpin org info -h

# headpin -u admin -p admin org info --name=test

# headpin -u admin -p admin org info --name=test -g

# headpin -u admin -p admin org info --name=test -v

# headpin -u admin -p admin org info --name=test --noheading

# headpin -u admin -p admin org info --name=test -g -v -d DELIMITER --noheading

  * List

# headpin org list -h

# headpin -u admin -p admin org list

# headpin -u admin -p admin org list -g

# headpin -u admin -p admin org list -v

# headpin -u admin -p admin org list --noheading

# headpin -u admin -p admin org list  -g -v -d DELIMITER --noheading

  * Subscriptions

# headpin org subscriptions -h

# headpin -u admin -p admin org subscriptions --name=ACME_Corporation (imported
the manifest to the org/registered the client system to the org)

# headpin -u admin -p admin org subscriptions --name=ACME_Corporation -g

# headpin -u admin -p admin org subscriptions --name=ACME_Corporation -v

# headpin -u admin -p admin org subscriptions --name=ACME_Corporation
--noheading

# headpin -u admin -p admin org subscriptions --name=ACME_Corporation  -g -v -d
DELIMITER --noheading

  * Update

# headpin org update -h

# headpin -u admin -p admin org update --name=
Resource not found on the server

# headpin -u admin -p admin org update --name=test
Successfully updated org [ test ]

# headpin -u admin -p admin org update --name=test --description=??
Successfully updated org [ test ]

  * add_default_system_info

# headpin org add_default_system_info -h

# headpin -u admin -p admin org add_default_system_info --name=test --keyname=
test
Successfully added default custom info key [ test ] to Org [ test ]

  * apply_default_system_info

# headpin org apply_default_system_info -h

# headpin -u admin -p admin org apply_default_system_info --name=test
Validation failed: Keyname can't be blank

  * remove_default_system_info

# headpin org remove_default_system_info -h

# headpin -u admin -p admin org remove_default_system_info --name=test
--keyname=test
Successfully removed default custom info key [ test ] for Org [ test ]

  * Delete

# headpin org delete -h

# headpin -u admin -p admin org delete --name=test

Deleting the organization, please wait...[\]
Successfully deleted org [ test ]  

 

 



Actual results: 
#FIXME

Expected results:
Messages are localized.
Comment 1 Lijun Li 2012-12-13 22:38:34 EST

*** This bug has been marked as a duplicate of bug 880066 ***

Note You need to log in before you can comment on or make changes to this bug.