Bug 880073 - [ALL_LANG][SAM CLI] Unlocalized strings for environment module.
[ALL_LANG][SAM CLI] Unlocalized strings for environment module.
Status: CLOSED NEXTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
medium Severity medium
: rc
: 2.0
Assigned To: Adam Price
SAM QE List
: Translation, Triaged
: 887079 (view as bug list)
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-26 02:38 EST by Lijun Li
Modified: 2013-06-07 14:28 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 14:28:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2012-11-26 02:38:54 EST
Description of problem:
Unlocalized strings for environment module.

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%


Steps to Reproduce:
# headpin environment create -h
Usage:  headpin <options> environment create <options>

Options:
  -h, --help            show this help message and exit
  --description=DESCRIPTION
                        環境の詳細、例: foo の環境
  --org=ORG             name of organization e.g.: ACME_Corporation (required)
  --name=NAME           環境名 (必須)
  --label=LABEL         environment label, ASCII identifier for the
                        environment with no spaces eg: Dev_One (will be
                        generated if not specified)
                        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
# headpin -u admin -p admin environment create --org=test --name=test --prior=Library --label=
Validation failed: Name 1 組織で一意である必要があります。, Label 1 組織で一意である必要が
^^^^^^^^^^^^^^^^Unlocalized
あります。

# headpin -u admin -p admin environment create --org=test --name=testqd --prior=test --label=??
Validation failed: Label cannot contain characters other than ascii alpha numerals, '_', '-'. 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin environment info --name=test --org=test
-------------------------------------------------------------------------------------
                                      環境情報
-------------------------------------------------------------------------------------

Id          : 40
Name        : test
Description:
^^^^^^^^^^^^^^^^^Unlocalized
    None
組織          : test
以前の環境       : Library

# headpin -u admin -p admin environment list --org=
Couldn't find organization 'environments'
^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin environment list --org=test
-------------------------------------------------------------------------------------
                                     環境の一覧

Id Name    Label   Description 組織   以前の環境  
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized    
-------------------------------------------------------------------------------------

# headpin -u admin -p admin environment delete --name=Library --org=test
Environment Library has a successor. Only the last environment on a path can be deleted.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized 



  
Actual results:
Unlocalized strings for environment module.

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Adam Price 2012-12-11 14:44:56 EST
Most column names are not localized. I will add them to localization, but it depends on if the translators get to them in time.

Most error messages that were coming from the server were being sent as English, so the CLI has no control over that. We are actively working on getting the error messages and validation error messages translated.
Comment 2 Noriko Mizumoto 2012-12-13 20:08:28 EST
confirmed for ja-JP
Comment 3 Lijun Li 2012-12-13 22:39:24 EST
*** Bug 887079 has been marked as a duplicate of this bug. ***
Comment 4 Eunju, Kim 2012-12-13 23:33:25 EST
confirmed for ko-KR
Comment 5 Hedda Peters 2012-12-13 23:38:59 EST
Similar result for de-DE, some strings mentioned above are localized though.
Comment 6 Sam Friedmann 2012-12-13 23:52:23 EST
Confirmed for fr-FR.
Comment 7 Tom McKay 2012-12-18 09:12:22 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 9 Bryan Kearney 2013-06-07 14:20:32 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 10 Bryan Kearney 2013-06-07 14:28:59 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.

Note You need to log in before you can comment on or make changes to this bug.