Bug 887079 - Test case failure: SAM CLI: environment
Test case failure: SAM CLI: environment
Status: CLOSED DUPLICATE of bug 880073
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 20:57 EST by Angela Garcia
Modified: 2012-12-13 22:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Not all messages are localized Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 22:39:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Angela Garcia 2012-12-13 20:57:11 EST
Not all messages are localized 


Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
SAM-20121130.n.0

Steps to Reproduce: 

# headpin environment -h

  * Create

# headpin environment create -h

# headpin -u admin -p admin environment create --org=test --name= --prior=
Could not find environment [  ] within organization [ test ]

# headpin -u admin -p admin environment create --org=test --name=test --prior=
Library
Successfully created environment [ test ]

# headpin -u admin -p admin environment create --org=test --name=test --prior=
Library --label=
Validation failed: Name must be unique within one organization, Label must be
unique within one organization

# headpin -u admin -p admin environment create --org=test --name=testqc --prior
=test --label=
Successfully created environment [ testqc ]

# headpin -u admin -p admin environment create --org=test --name=testqd --prior
=test --label=??
Validation failed: Label cannot contain characters other than ascii alpha
numerals, '_', '-'. , Prior environment can only have one child

# headpin -u admin -p admin environment create --org=test --name=testqf --prior
=Library --label=testqf
Successfully created environment [ testqf ]

# headpin -u admin -p admin environment create --org=test --name=testqq --prior
=Library --label=testqq --description=??
Successfully created environment [ testqq ]

  * Info

# headpin environment info -h

# headpin -u admin -p admin environment info --name=test
Could not find environment [ test ] within organization [ Starbucks ]

# headpin -u admin -p admin environment info --name=test --org=test

# headpin -u admin -p admin environment info --name=test --org=test -g

# headpin -u admin -p admin environment info --name=test --org=test -v

# headpin -u admin -p admin environment info --name=test --org=test --noheading

# headpin -u admin -p admin environment info --name=test --org=test -g -v -d
DELIMITER --noheading

  * List

# headpin environment list -h

# headpin -u admin -p admin environment list --org=
Couldn't find organization 'environments'

# headpin -u admin -p admin environment list --org=test

# headpin -u admin -p admin environment list --org=test -g

# headpin -u admin -p admin environment list --org=test -v

# headpin -u admin -p admin environment list --org=test --noheading

# headpin -u admin -p admin environment list --org=test -g -v -d DELIMITER
--noheading

  * Update

# headpin environment update -h

# headpin -u admin -p admin environment update --name=??
Could not find environment [ ?? ] within organization [ Starbucks

# headpin -u admin -p admin environment update --name=test --org=test
Successfully updated environment [ test ]

# headpin -u admin -p admin environment update --name=test --org=test --prior=
test
Validation failed: Prior environment can only have one child, Prior 
environment cannot be set to an environment already on its path

# headpin -u admin -p admin environment update --name=test --org=test --prior=
Library
Successfully updated environment [ test ]

# headpin -u admin -p admin environment update --name=test --org=test --prior=
Library --description=test
Successfully updated environment [ test ]

  * Delete

# headpin environment delete -h

]# headpin -u admin -p admin environment delete --name=test
Could not find environment [ test ] within organization [ Starbucks ]

# headpin -u admin -p admin environment delete --name=test --org=test
Environment test has a successor. Only the last environment on a path can be
deleted.

# headpin -u admin -p admin environment delete --name=Library --org=test
Environment Library has a successor. Only the last environment on a path can be
deleted.

# headpin -u admin -p admin environment delete --name=testqa --org=test
Successfully deleted environment [ testqa ]



Actual results: 
#FIXME

Expected results:
Messages are localized.
Comment 1 Lijun Li 2012-12-13 22:39:24 EST

*** This bug has been marked as a duplicate of bug 880073 ***

Note You need to log in before you can comment on or make changes to this bug.