Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 880111 - [RHEL 6.4] create a cluster will hang sometimes
Summary: [RHEL 6.4] create a cluster will hang sometimes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.2.0
Assignee: Gilad Chaplik
QA Contact: Jiri Belka
URL:
Whiteboard: infra
: 880102 (view as bug list)
Depends On:
Blocks: 917401
TreeView+ depends on / blocked
 
Reported: 2012-11-26 09:42 UTC by Guohua Ouyang
Modified: 2016-02-10 19:07 UTC (History)
16 users (show)

Fixed In Version: sf13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-11 09:12:33 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
cluster page settings (28.23 KB, image/png)
2013-02-16 02:00 UTC, Guohua Ouyang
no flags Details
sf11 - engine.log (5.57 KB, application/x-tar)
2013-03-22 08:57 UTC, Jiri Belka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 11507 0 None None None Never

Comment 6 Barak 2012-12-02 11:36:38 UTC
*** Bug 880102 has been marked as a duplicate of this bug. ***

Comment 9 Simon Grinberg 2012-12-24 18:15:09 UTC
Barak, was this farther investigated?

Comment 10 Barak 2013-01-02 14:37:01 UTC
(In reply to comment #9)
> Barak, was this farther investigated?
Not yet

Comment 12 Gilad Chaplik 2013-01-20 15:22:01 UTC
Hi Ouyang guohua, 
I need more info, is it a oVirt/gluster/both cluster.

Conclusions according to cluster type:
1) oVirt cluster: network table isn't indexed by storagePoolId.
2) Gluster Cluster: submit (press OK) does a LOT of extra work in the UI.
3) both: anyone's guess (I don't think we support it now).

* Note to self: add to server log, whether it's a oVirt/gluster/both AddVdsGroup command.

Thanks.

Comment 16 Gilad Chaplik 2013-02-14 14:52:53 UTC
it took me a while but now I think I got it.
the button shouldn't be enabled if no cluster is selected in the grid;
how did you manage to do so?

Comment 17 Guohua Ouyang 2013-02-16 02:00:16 UTC
Created attachment 698052 [details]
cluster page settings

(In reply to comment #16)
> it took me a while but now I think I got it.
> the button shouldn't be enabled if no cluster is selected in the grid;
> how did you manage to do so?

to create the cluster, just fill cluster name and cpu name can reproduce this issue. It's does not related to Data Center type or other factors as far as I see.

Comment 18 Gilad Chaplik 2013-02-17 09:19:07 UTC
look at the attached image:
there is no selected cluster in the grid, and I can't reproduce that.
maybe you are changing application mode (gluster/virt) ?

Comment 20 Jiri Belka 2013-03-06 10:31:27 UTC
OK, sf9, no hanged dialog.

Comment 22 Jiri Belka 2013-03-22 08:54:47 UTC
SF11 - The problem still exists when adding DC local type.

1. New DC
2. change type to Local on Host
3. OK

Hanged dialog, all other DC types were OK.

Comment 23 Jiri Belka 2013-03-22 08:57:30 UTC
Created attachment 714382 [details]
sf11 - engine.log

Comment 25 Jiri Belka 2013-04-05 10:10:29 UTC
ok, sf13.

Comment 26 Itamar Heim 2013-06-11 09:12:33 UTC
3.2 has been released

Comment 27 Itamar Heim 2013-06-11 09:39:27 UTC
3.2 has been released


Note You need to log in before you can comment on or make changes to this bug.