Bug 880384 - BUG: scheduling while atomic: swapper/0/0/0x10010000 during boot
BUG: scheduling while atomic: swapper/0/0/0x10010000 during boot
Status: CLOSED DUPLICATE of bug 869341
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 16:00 EST by Rolf Fokkens
Modified: 2012-11-28 11:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 11:13:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rolf Fokkens 2012-11-26 16:00:47 EST
Description of problem: after "yum update" the system generates several kernel oopses during boot on the console ending in a Kernel panic. In 50% of the cases the kernel just boots fine). 

Version-Release number of selected component (if applicable):
kernel-3.6.6-1.fc16.x86_64 

How reproducible: 50%

Steps to Reproduce:
1. reboot
2. enjoy the kernel oops
  
Actual results:
<3>[   15.593074] BUG: scheduling while atomic: swapper/0/0/0x10010000
<4>[   15.594079] Modules linked in: bridge stp llc be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi xt_CHECKSUM xt_LOG iptable_mangle xt_limit ipt_MASQUERADE xt_physdev xt_hl iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack_ipv6 nf_defrag_ipv4 nf_defrag_ipv6 xt_state nf_conntrack xt_hashlimit xt_multiport ip6table_filter ip6_tables iTCO_wdt iTCO_vendor_support snd_hda_codec_hdmi snd_hda_codec_realtek vfat fat binfmt_misc raid10 eeepc_wmi asus_wmi sparse_keymap rfkill coretemp crc32c_intel joydev ghash_clmulni_intel microcode serio_raw i2c_i801 lpc_ich mfd_core vhost_net macvtap macvlan tun kvm_intel snd_hda_intel snd_hda_codec snd_hwdep kvm snd_seq snd_seq_devicePanic#2 Part10
<4>[   15.597558]  snd_pcm uinput snd_timer snd soundcore snd_page_alloc e1000e sunrpc mxm_wmi wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video
<4>[   15.598740] Pid: 0, comm: swapper/0 Tainted: G      D W    3.6.6-1.fc16.x86_64 #1
<4>[   15.599909] Call Trace:
<4>[   15.601078]  <IRQ>  [<ffffffff8160f516>] __schedule_bug+0x4d/0x59
<4>[   15.602281]  [<ffffffff81618350>] __schedule+0x720/0x7c0
<4>[   15.603457]  [<ffffffff81533c12>] ? netlink_broadcast_filtered+0x122/0x380
<4>[   15.604633]  [<ffffffff8108f2ea>] __cond_resched+0x2a/0x40
<4>[   15.605812]  [<ffffffff81618472>] _cond_resched+0x32/0x40
<4>[   15.606986]  [<ffffffff8161744d>] mutex_lock+0x1d/0x50
<4>[   15.608164]  [<ffffffff811ff840>] sysfs_addrm_start+0x20/0x30
<4>[   15.609352]  [<ffffffff81200078>] sysfs_remove_dir+0x58/0xf0
<4>[   15.610524]  [<ffffffff812d6eb6>] kobject_del+0x16/0x40
<4>[   15.611689]  [<ffffffff812d6f4b>] kobject_release+0x6b/0x1d0
<4>[   15.612847]  [<ffffffff812d6dec>] kobject_put+0x2c/0x60
<4>[   15.614004]  [<ffffffff814cbab7>] efi_pstore_write+0x2b7/0x370
<4>[   15.615170]  [<ffffffff8105d2d2>] ? kmsg_dump_get_buffer+0x262/0x2c0
<4>[   15.616351]  [<ffffffff8126a04c>] pstore_dump+0x12c/0x200
<4>[   15.617517]  [<ffffffff8105ff2c>] kmsg_dump+0x9c/0xc0
<4>[   15.618672]  [<ffffffff8105c7c9>] oops_exit+0x29/0x30
<4>[   15.619829]  [<ffffffff8161a90e>] oops_end+0x7e/0xf0
<4>[   15.620973]  [<ffffffff8160e8ee>] no_context+0x276/0x285
<4>[   15.622129]  [<ffffffff81099f81>] ? load_balance+0x7a1/0x860
<4>[   15.623294]  [<ffffffff8160eace>] __bad_area_nosemaphore+0x1d1/0x1f0
<4>[   15.624414]  [<ffffffff81094c6d>] ? sched_clock_cpu+0xbd/0x110
<4>[   15.625499]  [<ffffffff8108e433>] ? update_rq_clock+0x43/0x1a0
<4>[   15.626548]  [<ffffffff8160eb00>] bad_area_nosemaphore+0x13/0x15
<4>[   15.627563]  [<ffffffff8161d546>] do_page_fault+0x416/0x4f0
<4>[   15.628545]  [<ffffffff8109a146>] ? rebalance_domains+0x106/0x180
<4>[   15.629523]  [<ffffffff8101baf9>] ? sched_clock+0x9/0x10
<4>[   15.630498]  [<ffffffff81084d22>] ? hrtimer_get_next_event+0xf2/0x100
<4>[   15.631474]  [<ffffffff81619d65>] page_fault+0x25/0x30
<4>[   15.632437]  [<ffffffff8103bc45>] ? smp_irq_move_cleanup_interrupt+0xc5/0x150
<4>[   15.633418]  [<ffffffff8103bc41>] ? smp_irq_move_cleanup_interrupt+0xc1/0x150
<4>[   15.634389]  [<ffffffff81622267>] irq_move_cleanup_interrupt+0x67/0x70
<4>[   15.635359]  <EOI>  [<ffffffff81332ded>] ? intel_idle+0xed/0x150
<4>[   15.636336]  [<ffffffff81332dcf>] ? intel_idle+0xcf/0x150
<4>[   15.637320]  [<ffffffff814c62d9>] cpuidle_enter+0x19/0x20
<4>[   15.638295]  [<ffffffff814c696c>] cpuidle_idle_call+0xac/0x290
<4>[   15.639279]  [<ffffffff8101d74f>] cpu_idle+0xcf/0x120
<4>[   15.640261]  [<ffffffff815f5cde>] rest_init+0x72/0x74
<4>[   15.641245]  [<ffffffff81cfcc31>] start_kernel+0x3c7/0x3d4
<4>[   15.642227]  [<ffffffff81cfc66a>] ? repair_env_string+0x5a/0x5a
<4>[   15.643199]  [<ffffffff81cfc356>] x86_64_start_reservations+0x131/0x135
<4>[   15.644179]  [<ffffffff81cfc120>] ? early_idt_handlers+0x120/0x120
<4>[   15.645169]  [<ffffffff81cfc45c>] x86_64_start_kernel+0x102/0x111
<0>[   16.036608] Kernel panic - not syncing: Fatal exception in interrupt

Expected results: smooth boot

Additional info: BUG 607698
Comment 1 Josh Boyer 2012-11-28 11:13:54 EST
This is most likely a duplicate of 869341

*** This bug has been marked as a duplicate of bug 869341 ***

Note You need to log in before you can comment on or make changes to this bug.