Bug 869341 - NULL pointer dereference at irq_move_cleanup_interrupt during boot
NULL pointer dereference at irq_move_cleanup_interrupt during boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
: 872216 875722 879414 880384 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 11:53 EDT by Ian Collier
Modified: 2014-09-13 15:00 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-21 22:51:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Photograph of the kernel panic message (734.72 KB, image/png)
2012-10-23 11:53 EDT, Ian Collier
no flags Details
Hand-transcription of the kernel panic message (apols for any typos) (2.83 KB, text/plain)
2012-10-23 11:54 EDT, Ian Collier
no flags Details
Another photograph of crash-log (580.53 KB, image/jpeg)
2012-10-26 18:29 EDT, Clemens Eisserer
no flags Details
Another photograph of crash-log (580.53 KB, image/jpeg)
2012-10-26 18:31 EDT, Clemens Eisserer
no flags Details

  None (edit)
Description Ian Collier 2012-10-23 11:53:01 EDT
Created attachment 632172 [details]
Photograph of the kernel panic message

Description of problem:
We have a lab of 50 Dell Optiplex 9010 SFF PCs running Fedora 17 and all updated to kernel 3.6.2.  On any one day when they are all switched on, about 5-10 of the machines will either get stuck on the Plymouth boot screen or display a kernel panic message at approximately 16-17 seconds from boot.

Since this seems to happen at a network interrupt, it may be relevant that we have uninstalled NetworkManager and are using the SYSV "network" service.  The crash happens at about the time the system starts up that service.

Version-Release number of selected component (if applicable):
kernel-3.6.2-4.fc17.x86_64

How reproducible:
about 1 in every 10 boots

Steps to Reproduce:
1. Turn the machine on
Comment 1 Ian Collier 2012-10-23 11:54:32 EDT
Created attachment 632173 [details]
Hand-transcription of the kernel panic message (apols for any typos)
Comment 2 Ian Collier 2012-10-23 13:17:59 EDT
This looks relevant:
http://lkml.org/lkml/2012/10/16/261

It's blowing up at exactly the line

                if (cfg->move_in_progress)

in arch/x86/kernel/apic/io_apic.c (line 2266).

(Author of the above post says this was "raised a while back" - that seems to mean in May 2012.  There was a dispute as to whether the check should go before or after the lock is taken.)
Comment 3 Clemens Eisserer 2012-10-26 18:29:02 EDT
Experienced this crash during boot on my new dell laptop with Fedora-17+updates-testing running kernel 3.6.3-1.fc17.x86_64.

Photo of crash log is attached.
Comment 4 Clemens Eisserer 2012-10-26 18:29:43 EDT
Created attachment 634071 [details]
Another photograph of crash-log
Comment 5 Clemens Eisserer 2012-10-26 18:31:35 EDT
Created attachment 634072 [details]
Another photograph of crash-log
Comment 6 Chris Shoemaker 2012-11-02 11:19:32 EDT
This happens on a Dell Precision M4600, too.
Comment 7 Josh Boyer 2012-11-02 12:30:35 EDT
*** Bug 872216 has been marked as a duplicate of this bug. ***
Comment 8 Marcus Moeller 2012-11-12 04:36:09 EST
Has been fixed in kernel-3.6.6-3
Comment 9 Josh Boyer 2012-11-12 10:56:52 EST
We've had reports of this not being fixed with 3.6.6-3.  Reopening.
Comment 10 Josh Boyer 2012-11-12 10:57:09 EST
*** Bug 875722 has been marked as a duplicate of this bug. ***
Comment 11 Josh Boyer 2012-11-12 11:07:23 EST
Could people seeing this issue please boot this kernel when it completes building and let me know if the issue seems to be resolved:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4679582
Comment 12 Marcus Moeller 2012-11-12 14:00:27 EST
I have tried to reproduce it with kernel-3.6.6-4.fc18, no errors occured (on a machine that previously ran into the trace on every boot). Re-booted ~10 cycles without a problem.

Tried the same with kernel-3.6.6-1.fc17. The problem still seems to exist here.

I am going to re-check it with your updated build.
Comment 13 Marcus Moeller 2012-11-13 04:59:46 EST
Also verified with the 4679582 build. Tested about 15 cycles without any problem.
Comment 14 Chris Shoemaker 2012-11-15 10:15:32 EST
Will this fix be released for f17?
Comment 15 Josh Boyer 2012-11-16 08:37:29 EST
(In reply to comment #14)
> Will this fix be released for f17?

Yes.  A patch went into the fedora git tree yesterday.
Comment 16 Fedora Update System 2012-11-16 13:17:27 EST
kernel-3.6.6-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.6-9.fc18
Comment 17 Fedora Update System 2012-11-16 21:28:09 EST
Package kernel-3.6.6-9.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.6-9.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18361/kernel-3.6.6-9.fc18
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2012-11-19 07:57:24 EST
kernel-3.6.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.7-1.fc18
Comment 19 Fedora Update System 2012-11-19 17:17:28 EST
kernel-3.6.7-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.6.7-2.fc16
Comment 20 Fedora Update System 2012-11-19 17:18:49 EST
kernel-3.6.7-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.7-2.fc17
Comment 21 Fedora Update System 2012-11-20 16:32:04 EST
kernel-3.6.7-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.7-5.fc18
Comment 22 Fedora Update System 2012-11-20 16:38:14 EST
kernel-3.6.7-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.7-4.fc17
Comment 23 Fedora Update System 2012-11-21 22:51:53 EST
kernel-3.6.7-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Fedora Update System 2012-11-26 23:41:56 EST
kernel-3.6.7-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Josh Boyer 2012-11-27 13:28:20 EST
*** Bug 879414 has been marked as a duplicate of this bug. ***
Comment 26 Fedora Update System 2012-11-28 06:30:23 EST
kernel-3.6.7-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2012-11-28 08:29:12 EST
kernel-3.6.8-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.8-2.fc17
Comment 28 Josh Boyer 2012-11-28 11:13:54 EST
*** Bug 880384 has been marked as a duplicate of this bug. ***
Comment 29 Fedora Update System 2012-12-01 03:27:15 EST
kernel-3.6.8-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.