Bug 880413 - Headpin install is broken.
Headpin install is broken.
Status: CLOSED WORKSFORME
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jordan OMara
SAM QE List
:
: 880536 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 17:55 EST by Gerhard Stoeckel
Modified: 2014-11-09 17:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 08:04:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output from katello-debug (88.08 KB, application/x-gzip)
2012-11-27 09:29 EST, Gerhard Stoeckel
no flags Details

  None (edit)
Description Gerhard Stoeckel 2012-11-26 17:55:57 EST
Description of problem:
Headpin install fails when attempting to start katello-jobs service with the following error:

/Stage[main]/Katello::Service/Service[katello-jobs]/ensure: change from stopped to running failed: Could not start Service[katello-jobs]: Execution of '/sbin/service katello-jobs start' returned 1:  at /usr/share/katello/install/puppet/modules/katello/manifests/service.pp

Version-Release number of selected component (if applicable):


How reproducible: Very


Steps to Reproduce:
1.yum install  -y katello-headpin-all
2.yum -y update
3.katello-configure --deployment=headpin'

  
Actual results:


Expected results:


Additional info:
Comment 1 Tom McKay 2012-11-27 07:53:12 EST
Please attach output from katello-debug
Comment 2 Gerhard Stoeckel 2012-11-27 09:29:21 EST
Created attachment 652785 [details]
Output from katello-debug
Comment 3 Tom McKay 2012-11-27 11:39:49 EST
*** Bug 880536 has been marked as a duplicate of this bug. ***
Comment 4 Jordan OMara 2012-11-28 12:03:12 EST
From the logs, this is a simple fencing error:

Using gem require instead of bundler
/usr/share/katello/app/controllers/domains_controller.rb:18: uninitialized constant Foreman (NameError)
	from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
	from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'

Note You need to log in before you can comment on or make changes to this bug.