Bug 880485 - RHEL7 qemu-kvm should provide RHEL6-compatible and RHEL7-specific machine types
RHEL7 qemu-kvm should provide RHEL6-compatible and RHEL7-specific machine types
Status: CLOSED DUPLICATE of bug 889670
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Luiz Capitulino
Virtualization Bugs
:
Depends On: 960216
Blocks: 720747 895240
  Show dependency treegraph
 
Reported: 2012-11-27 00:32 EST by juzhang
Modified: 2013-05-06 13:35 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-18 14:20:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description juzhang 2012-11-27 00:32:42 EST
Description of problem:


Version-Release number of selected component (if applicable):
qemu-kvm-1.2.0-20.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1.#/usr/libexec/qemu-kvm -M ?

2.
3.
  
Actual results:
Supported machines are:
none                 empty machine
pc                   Standard PC (alias of pc-1.2)
pc-1.2               Standard PC (default)
pc-1.1               Standard PC
pc-1.0               Standard PC
pc-0.15              Standard PC
pc-0.14              Standard PC
pc-0.13              Standard PC
pc-0.12              Standard PC
pc-0.11              Standard PC, qemu 0.11
pc-0.10              Standard PC, qemu 0.10
isapc                ISA-only PC


Expected results:
/usr/libexec/qemu-kvm -M ?
Supported machines are:
pc         RHEL 6.4.0 PC (alias of rhel7.0.0)
rhel7.0.0  RHEL 7.0.0 PC (default)
.......


Additional info:
I tried latest qemu(1.3rc1) upstream, the result is not friendly.
#./qemu-system-x86_64 -M ?
Supported machines are:
none                 empty machine
pc                   Standard PC (alias of pc-1.3)
pc-1.3               Standard PC (default)
pc-1.2               Standard PC
pc-1.1               Standard PC
pc-1.0               Standard PC
pc-0.15              Standard PC
pc-0.14              Standard PC
pc-0.13              Standard PC
pc-0.12              Standard PC
pc-0.11              Standard PC, qemu 0.11
pc-0.10              Standard PC, qemu 0.10
isapc                ISA-only PC
q35                  Q35 chipset PC (alias of q35-next)
q35-next             Q35 chipset PC
Comment 1 Luiz Capitulino 2012-11-27 14:37:46 EST
I believe that the RHEL machine types will only be created when we fork qemu 1.3 for RHEL, which should happen soon.

CC'ing a few folks who are more familiar with the RHEL machine types than me, so that then can chime in if necessary (or even take the bz).
Comment 2 Eduardo Habkost 2012-11-28 08:10:45 EST
True. We won't create the rhel7.0.0 machine-type until we create a RHEL7-specific tree, after QEMU 1.3 is released. When we do that, it will probably be based on the existing "pc-1.3" machine-type.
Comment 3 Paolo Bonzini 2013-03-15 06:59:56 EDT
Additional note from Markus:

> Enabling/disabling KVM is guest-visible upstream.  With KVM disabled,
> you get a flash memory device.  With KVM enabled, you get a ROM.  Not
> good; KVM should be as transparent as possible to the guest.
>
> Looks like we should set "pc-sysfw" property "rom_only" to 1 for all
> RHEL machine types.
Comment 4 Luiz Capitulino 2013-04-18 14:20:30 EDT
Talked with Eduardo about this BZ and he suggested closing this as a dupe of bug 889670 because we need the missing machine types to support migration to RHEL7.0.

*** This bug has been marked as a duplicate of bug 889670 ***

Note You need to log in before you can comment on or make changes to this bug.