Bug 880523 - [rhevm-upgrade] Rollback steps should be printed to a user when failing on DB upgrade
[rhevm-upgrade] Rollback steps should be printed to a user when failing on DB...
Status: CLOSED DUPLICATE of bug 920712
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
urgent Severity urgent
: ---
: 3.2.0
Assigned To: Juan Hernández
Pavel Stehlik
integration
:
Depends On:
Blocks: 884642
  Show dependency treegraph
 
Reported: 2012-11-27 03:54 EST by Kiril Nesenko
Modified: 2014-07-10 20:09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 884642 (view as bug list)
Environment:
Last Closed: 2013-03-27 06:08:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
logs (243.55 KB, text/x-log)
2012-11-27 03:54 EST, Kiril Nesenko
no flags Details

  None (edit)
Description Kiril Nesenko 2012-11-27 03:54:37 EST
Created attachment 652540 [details]
logs

Description of problem:
 Rollback steps should be printed to a user when failing on DB upgrade

Stopping ovirt-engine service...                         [ DONE ]
Stopping DB related services...                          [ DONE ]
Pre-upgrade validations...                               [ DONE ]
Preparing system for 3.1 upgrade...                      [ DONE ]
Backing Up Database...                                   [ DONE ]
Rename Database...                                       [ DONE ]
Updating rpms...                                         [ DONE ]
Updating Database...                                     [ ERROR ]

 **Error: Upgrade failed, rolling back**
 **Reason: Error: Database update failed**

Restoring Database...                                    [ DONE ]
Skipping yum rollback
Starting ovirt-engine...                                 [ DONE ]
Error: Upgrade failed.
please check log at /var/log/ovirt-engine/ovirt-engine-upgrade_2012_11_27_10_25_54.log
* DB Backup available at  /var/lib/ovirt-engine/backups/ovirt-engine_db_backup_2012_11_27_10_25_54.sql

Version-Release number of selected component (if applicable):
rhevm-3.1.0-31.el6ev.noarch.rpm

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 6 Alex Lourie 2013-03-27 06:08:57 EDT

*** This bug has been marked as a duplicate of bug 920712 ***

Note You need to log in before you can comment on or make changes to this bug.