Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 880687 - engine: event log is reporting changing disk status to illegal but disks stay in locked state
Summary: engine: event log is reporting changing disk status to illegal but disks stay...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.1.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 3.2.0
Assignee: Maor
QA Contact: Haim
URL:
Whiteboard: storage
Depends On:
Blocks: 902482 915537
TreeView+ depends on / blocked
 
Reported: 2012-11-27 15:36 UTC by Dafna Ron
Modified: 2016-02-10 17:45 UTC (History)
13 users (show)

Fixed In Version: sf5
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 902482 (view as bug list)
Environment:
Last Closed: 2012-11-28 10:17:52 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)
logs and screen shots (1.01 MB, application/x-gzip)
2012-11-27 15:36 UTC, Dafna Ron
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 11075 0 None None None Never
oVirt gerrit 11248 0 None None None Never

Description Dafna Ron 2012-11-27 15:36:48 UTC
Created attachment 652827 [details]
logs and screen shots

Description of problem:

create 5 vm's select 3 -> remove -> select the other 2 -> remove -> restart engine. 

Version-Release number of selected component (if applicable):

si24.4

How reproducible:

100%

Steps to Reproduce:

1. create 5 vm's
2. select 3 vms -> remove them
3. select 2 vm's -> remove them
4. restart engine
  
Actual results:

some of the disks are reported to be changed to illegal state but stay in locked state

Expected results:

disks should not remain locked. 

Additional info: logs


this also reproduces on scale:

Steps to Reproduce:
1. create 100VM's 
2. remove all vm's but in bulks of 10-15 vm's (select 15 -> remove -> select 15 -> remove)
3. restart engine.

Comment 1 Allon Mureinik 2012-11-28 09:58:59 UTC
Dafna, this seems to be like 2 bugs: incorrect reporting in the event log and the disks remaining locked.
Can you please separate it to two bugs?

Also - do the async tasks remains as zombies, or are they cleared?

Comment 2 Allon Mureinik 2012-11-28 10:17:52 UTC

*** This bug has been marked as a duplicate of bug 840525 ***

Comment 3 Dafna Ron 2012-11-28 10:21:24 UTC
Alon, this bug is about the event log reporting that the disk status has been changed to illegal while they stay in image locked. 
not related to  bug 840525
reopening this bug

Comment 5 Maor 2013-01-20 20:41:21 UTC
The event log should be correct.
If disks remain after VM was removed they should move to illegal state, if some of the disks were in other status, then this is a bug.

Comment 7 Maor 2013-01-21 08:44:54 UTC
Already fixed at http://gerrit.ovirt.org/#/c/11075/

Comment 9 Maor 2013-01-21 12:52:46 UTC
Added also a fix which change all the remained disks statuses to illegal with a log message

Comment 10 Maor 2013-01-21 14:39:18 UTC
Patch merged with change id Ic4075c03b8d70d50b69222c73169ccc63e3ab66e

Comment 12 Leonid Natapov 2013-02-04 15:30:59 UTC
sf5. fixed. disk becomes illegal (not locked) if the engine/vdsm was restarted during vm deletion.

Comment 13 Itamar Heim 2013-06-11 08:49:40 UTC
3.2 has been released

Comment 14 Itamar Heim 2013-06-11 08:49:40 UTC
3.2 has been released

Comment 15 Itamar Heim 2013-06-11 08:49:40 UTC
3.2 has been released

Comment 16 Itamar Heim 2013-06-11 08:54:09 UTC
3.2 has been released

Comment 17 Itamar Heim 2013-06-11 09:24:45 UTC
3.2 has been released


Note You need to log in before you can comment on or make changes to this bug.