Bug 902482 - engine: event log is reporting changing disk status to illegal but disks stay in locked state
engine: event log is reporting changing disk status to illegal but disks stay...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.1.3
Assigned To: Maor
vvyazmin@redhat.com
storage
: Reopened, ZStream
Depends On: 880687
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-21 13:55 EST by Idith Tal-Kohen
Modified: 2016-02-10 15:26 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when attempting to delete multiple images in quick succession, the image status would remain locked. This has been corrected so that the image status is correctly set to illegal.
Story Points: ---
Clone Of: 880687
Environment:
Last Closed: 2013-03-12 10:28:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs vdsm, rhevm (793.57 KB, application/x-gzip)
2013-02-10 10:34 EST, vvyazmin@redhat.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11075 None None None Never
oVirt gerrit 11248 None None None Never

  None (edit)
Comment 2 vvyazmin@redhat.com 2013-02-10 10:34:18 EST
Failed on RHEVM 3.1 - SI27 environment:

RHEVM: rhevm-3.1.0-46.el6ev.noarch
VDSM: vdsm-4.10.2-7.0.el6ev.x86_64
LIBVIRT: libvirt-0.10.2-18.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.348.el6.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64

Steps to Reproduce:
1. create 50VM's 
2. remove all vm's but in bulks of 10-15 vm's (select 15 -> remove -> select 15 -> remove)
3. restart engine.

psql -U postgres engine -c 'select vm_names,disk_id,disk_alias,imagestatus  from all_disks where imagestatus = 2;'  | less -S 
 vm_names  |               disk_id                |  disk_alias   | imagestatus 
-----------+--------------------------------------+---------------+-------------
 100-vm-2  | 578edec4-c1e7-4d4d-940d-c1373e8ac1cd | vm-base_Disk1 |           2
 100-vm-28 | d3add837-2f74-40d4-98d5-6cce2cf76aa9 | vm-base_Disk1 |           2
(2 rows)
Comment 3 vvyazmin@redhat.com 2013-02-10 10:34:51 EST
Created attachment 695801 [details]
## Logs vdsm, rhevm
Comment 6 vvyazmin@redhat.com 2013-02-11 14:17:36 EST
No issues are found

Verified on RHEVM 3.1.3 - SI27 environment:

RHEVM: rhevm-3.1.0-46.el6ev.noarch
VDSM: vdsm-4.10.2-7.0.el6ev.x86_64
LIBVIRT: libvirt-0.10.2-18.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.348.el6.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64
Comment 8 errata-xmlrpc 2013-03-12 10:28:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0557.html

Note You need to log in before you can comment on or make changes to this bug.