Bug 880879 - Undo button causing repeated save failures and other weirdness
Undo button causing repeated save failures and other weirdness
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 2.1
Assigned To: Patrick Huang
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-27 21:19 EST by Hedda Peters
Modified: 2013-02-25 23:06 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.1-SNAPSHOT (20121206-1113)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 23:06:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-11-27 21:19:14 EST
Description of problem:
I encountered a failed save operation when trying out the undo-button on a message that I translated just before. After that failed save, I seem to be unable to save that entry no matter what I do (bar reloading the whole page, which I haven't tried yet)


How reproducible:
not sure


Additional info:

https://translate.engineering.redhat.com/webtrans/translate?project=rhn-satellite-user-guide&iteration=5.5&localeId=de&locale=de#view:doc;doc:OpenSCAP;projectsearch:compliance 

	
[12:09:07] Save FAILED: id 182189
[12:09:25] Save FAILED: id 182189
[12:09:39] Save FAILED: id 182189
... (some succesful operations on other strings)
[12:14:38] Save FAILED: id 182189
Comment 1 Hedda Peters 2012-11-27 22:07:22 EST
I reloaded the browser's page now, and the troublesome entry appears translated/approved.
Comment 2 Patrick Huang 2012-11-27 22:20:45 EST
It maybe related to bug 873525
Comment 3 Patrick Huang 2012-11-27 22:24:23 EST
(In reply to comment #1)
> I reloaded the browser's page now, and the troublesome entry appears
> translated/approved.

Does this mean it's saved even though the notification says failed? I can see a bunch of translation history entries within minutes
Comment 4 Hedda Peters 2012-11-27 22:34:25 EST
(In reply to comment #3)
> (In reply to comment #1)
> > I reloaded the browser's page now, and the troublesome entry appears
> > translated/approved.
> 
> Does this mean it's saved even though the notification says failed? I can
> see a bunch of translation history entries within minutes

Possibly. What I did was somthing like this:

1) Entry was untranslated, I translated as "ABC" and saved successfully.
2) I moved on to different entry and translated something else
3) Came back to original entry and changed translation to "ABC test" - I *think* this save operation still succeeded, although not entirely sure now.
4) I then changed the translation back to "ABC", but this save operation produced the error message of failed save.
5) Tried again multiple times to save the translation "ABC", it kept failing. The entry was highlighted in blue indicating unsaved changes

After the page reload the correct translation "ABC" was shown, but I can't tell from which save-operation that translation comes exactly.
Comment 5 Sean Flanigan 2012-11-27 23:01:30 EST
Where in those steps did you use Undo?  And by that did you mean the Cancel Changes button?  Or was it the history button?
Comment 6 Hedda Peters 2012-11-27 23:33:26 EST
(In reply to comment #5)
> Where in those steps did you use Undo?  And by that did you mean the Cancel
> Changes button?  Or was it the history button?

No, you're right - I missed that. I used the "Undo" button at step 4. (Which now confirms that the save in step 3 must have worked). So I wanted to use the "Undo" button to change the translation back from "ABC test" to "ABC", which failed.

Sorry for the confusion, I didn't pay too much attention at the time, not expecting to having to try to reproduce.
Comment 7 Sean Flanigan 2012-11-28 00:39:58 EST
Thanks Hedda, but I'm still not clear on what button you pressed.  What do you mean by the Undo button in this case?
Comment 9 Sean Flanigan 2012-11-28 01:45:54 EST
Oh, that Undo button!  Duh, sorry!  I forget we'd finally implemented that.

If I use Undo for step 4, it undoes 'ABCtest' and changes it back to 'ABC' (in the database, if you refresh the page or look at the TM results you can see it), but it leaves the field on the screen empty.  Then if you type something, the 'ABC' suddenly appears.  It still saves okay for me, so I can't reproduce this bug, but we certainly need to look at Undo.
Comment 10 Patrick Huang 2012-11-29 22:00:26 EST
cannot reproduce it. But I did fix the blank field symptom (sign for CodeMirror refresh) after undo. 
Fix commit in : https://github.com/zanata/zanata/commit/50d04fc713711b5e62db0d26aab529028b3ce49b
Comment 11 Ding-Yi Chen 2012-12-05 21:29:05 EST
VERIFIED with Zanata version 2.1-SNAPSHOT (20121206-1113)

Note You need to log in before you can comment on or make changes to this bug.