Bug 880933 - Selective importing of distros
Summary: Selective importing of distros
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: lab controller
Version: 0.10
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: 0.12
Assignee: Raymond Mancy
QA Contact: Amit Saha
URL:
Whiteboard: DistroManagement
Keywords: FutureFeature
: 847912 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-28 08:08 UTC by Raymond Mancy
Modified: 2018-02-06 00:41 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-04-11 04:56:28 UTC


Attachments (Terms of Use)

Description Raymond Mancy 2012-11-28 08:08:57 UTC
beaker-import needs to be more flexible so we can import selectively from composes, either by specifically selecting trees, or by not dying the some trees do not exist

Comment 1 Raymond Mancy 2013-02-04 06:21:35 UTC
http://gerrit.beaker-project.org/#/c/1522/

Comment 2 Raymond Mancy 2013-02-04 06:22:16 UTC
I'd also like to add the ability to add all the relevant repos when importing from the tree level.

Comment 9 Raymond Mancy 2013-03-28 02:35:05 UTC
This changes makes two fundamental changes to the possibilities of distro importing. The first is
that no assumption is made as to the trees that exist within a compose. This means, that if you wish
to pass a compose URL to beaker-import, it will import all valid trees it can find,
and not abort if expected trees are not found. Inversely, we can now specify which trees we want 
imported by using the --arch and --variant options. This allows us to only import those trees
which are of relevance.

Secondly, we now attempt to treat tree level imports as we do composes. That is, we attempt
to populate trees imported at the tree level with the same data as if they had been imported
indirectly from the compose level. Historically and specifically, this has been an issue with regards
to repos, where trees imported at the tree level were befeft of certain repos. Unfortunately, we cannot
guarantee the same level of accuracy as we can if importing
from the compose level (at least with RHEL7, Fedora), as the compose informs us of the location of all
relevant repos. If we are importing at the tree level, we rely on hard coding 'known' locations, where
we expect the repos to be.

Comment 10 Raymond Mancy 2013-03-28 03:33:42 UTC
http://gerrit.beaker-project.org/#/c/1839/1

Comment 12 Raymond Mancy 2013-04-02 09:53:26 UTC
previous commit was abandoned. New commit is http://gerrit.beaker-project.org/#/c/1843/.

Comment 13 Amit Saha 2013-04-02 13:48:15 UTC
Setting status to MODIFIED since the patch is merged.

Comment 15 Amit Saha 2013-04-02 14:00:58 UTC
Or, rather I am just going to keep it ON_QA, since the packages aren't built yet. But yeah, feel free to set it to VERIFIED. It seems to work fine.

Comment 16 Amit Saha 2013-04-03 12:56:53 UTC
In fact, i think it should be MODIFIED. Sorry for the spam.

Comment 19 Dan Callaghan 2013-04-11 04:56:28 UTC
Beaker 0.12 has been released.

Comment 20 Raymond Mancy 2013-04-12 04:05:23 UTC
*** Bug 847912 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.