This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 881425 - NullPointerException in GTK file dialog when choosing from "recently used files"
NullPointerException in GTK file dialog when choosing from "recently used files"
Status: CLOSED DUPLICATE of bug 928500
Product: Fedora
Classification: Fedora
Component: arduino (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Oliver
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-28 16:35 EST by Brendan Jackman
Modified: 2013-03-27 15:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-27 15:12:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
~/local/share/recently-used.xbel (756 bytes, text/plain)
2012-11-28 16:38 EST, Brendan Jackman
no flags Details

  None (edit)
Description Brendan Jackman 2012-11-28 16:35:30 EST
Description of problem:
When opening a file from GTK's "recently used files", the following exception is thrown:

Exception in thread "Thread-0" java.lang.NullPointerException
        at sun.awt.X11.GtkFileDialogPeer.setFileInternal(GtkFileDialogPeer.java:79)
        at sun.awt.X11.GtkFileDialogPeer.run(Native Method)
        at sun.awt.X11.GtkFileDialogPeer.showNativeDialog(GtkFileDialogPeer.java:172)
        at sun.awt.X11.GtkFileDialogPeer.access$000(GtkFileDialogPeer.java:39)
        at sun.awt.X11.GtkFileDialogPeer$1.run(GtkFileDialogPeer.java:114)

The user interface stops responding to events (however the application is still redrawn and other threads continue. I'm not sure how to inspect further..

Version-Release number of selected component (if applicable):
Version     : 1.0.1
Release     : 1.fc17

How reproducible:
File >> Open >> Select any file from "recently used files".

Problem persists after reboot and after removing (then re-populating by opening files) ~.local/share/recently-used.xbel. I have attached the contents of that file when it only contains one element.

On my installation arduino reports on launch:

WARNING:  RXTX Version mismatch
        Jar version = RXTX-2.2
        native lib Version = RXTX-2.2pre2
$ yum search rxtx
(...)
Version     : 2.2
Release     : 0.6.20100211.fc17.1

(I can't see how that would be related but I have reported it just in case!)
Comment 1 Brendan Jackman 2012-11-28 16:38:12 EST
Created attachment 653769 [details]
~/local/share/recently-used.xbel
Comment 2 Gianluca Sforna 2013-03-27 15:12:14 EDT
This is really a bug in openjdk, I opened bug #928500 with a patch, let's hope it lands soonish

*** This bug has been marked as a duplicate of bug 928500 ***

Note You need to log in before you can comment on or make changes to this bug.