Bug 928500 - GTK file dialog crashes with a NPE [PATCH]
GTK file dialog crashes with a NPE [PATCH]
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: java-1.7.0-openjdk (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mario Torre
Fedora Extras Quality Assurance
:
: 881425 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-27 15:08 EDT by Gianluca Sforna
Modified: 2013-04-22 04:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-22 04:57:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gianluca Sforna 2013-03-27 15:08:35 EDT
Description of problem:

If I try to open a file and then select a file from the 'recently used'
documents list the file dialog crashes. Here is the full exception.

Exception in thread "Thread-10" java.lang.NullPointerException
    at sun.awt.X11.GtkFileDialogPeer.setFileInternal(GtkFileDialogPeer.java:79)
    at sun.awt.X11.GtkFileDialogPeer.run(Native Method)
    at
sun.awt.X11.GtkFileDialogPeer.showNativeDialog(GtkFileDialogPeer.java:166)
    at sun.awt.X11.GtkFileDialogPeer.access$000(GtkFileDialogPeer.java:39)
    at sun.awt.X11.GtkFileDialogPeer$1.run(GtkFileDialogPeer.java:108)

This is known upstream in:
http://bugs.sun.com/view_bug.do?bug_id=7130662

and a patch is available:
http://hg.openjdk.java.net/jdk8/awt/jdk/raw-diff/89bc9d08fe82/src/solaris/classes/sun/awt/X11/GtkFileDialogPeer.java

Please consider applying it
Comment 1 Gianluca Sforna 2013-03-27 15:12:14 EDT
*** Bug 881425 has been marked as a duplicate of this bug. ***
Comment 2 Mario Torre 2013-03-27 15:25:40 EDT
Hello Gianluca,

Since a patch has been pushed upstream already, we need to wait for the fix to be backported in 7.

I'll take care to ask for the backport asap.

Thanks for reporting this,

Mario
Comment 3 Andrew John Hughes 2013-04-02 20:32:09 EDT
No movement on this in the last week, so I posted this for backport:

http://mail.openjdk.java.net/pipermail/jdk7u-dev/2013-April/006047.html
Comment 4 Andrew John Hughes 2013-04-03 11:31:08 EDT
This was approved:

http://hg.openjdk.java.net/jdk7u/jdk7u-dev/jdk/rev/885ad3351534

It's also now in IcedTea:

http://icedtea.classpath.org/hg/icedtea7-forest/jdk/rev/885ad3351534

and should be included in the next security update.
Comment 5 Mario Torre 2013-04-22 04:57:57 EDT
Closing this bug now, since the back port has been done and released.

Note You need to log in before you can comment on or make changes to this bug.