Bug 881534 - python-novaclient needs Requires: python-iso8601
python-novaclient needs Requires: python-iso8601
Status: CLOSED DUPLICATE of bug 881515
Product: Red Hat OpenStack
Classification: Red Hat
Component: distribution (Show other bugs)
1.0 (Essex)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Yaniv Kaul
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-28 22:38 EST by Andrew Beekhof
Modified: 2013-07-03 22:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 04:52:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Beekhof 2012-11-28 22:38:03 EST
Description of problem:

Missing dependancy on fedora-18 leading to python exception

Version-Release number of selected component (if applicable):

python-novaclient.noarch 1:2.9.0-1.fc18 

How reproducible:

Every time

Steps to Reproduce:
1. yum install python-novaclient
2. nova list
3.
  
Actual results:

[root@fedora-18-base ~]# nova list
Traceback (most recent call last):
  File "/bin/nova", line 9, in <module>
    load_entry_point('python-novaclient==2.9.0', 'console_scripts', 'nova')()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 337, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2311, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2017, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.7/site-packages/novaclient/shell.py", line 36, in <module>
    from novaclient.v1_1 import shell as shell_v1_1
  File "/usr/lib/python2.7/site-packages/novaclient/v1_1/shell.py", line 27, in <module>
    from novaclient.openstack.common import timeutils
  File "/usr/lib/python2.7/site-packages/novaclient/openstack/common/timeutils.py", line 25, in <module>
    import iso8601
ImportError: No module named iso8601

Expected results:

[root@fedora-18-base ~]# nova list
ERROR: You must provide a username via either --os-username or env[OS_USERNAME]

Additional info:

Works after installing python-iso8601.noarch 0:0.1.4-5.fc18
Comment 2 Alan Pevec 2012-11-29 04:52:16 EST

*** This bug has been marked as a duplicate of bug 881515 ***
Comment 3 Andrew Beekhof 2012-11-29 19:32:55 EST
(In reply to comment #2)
> 
> *** This bug has been marked as a duplicate of bug 881515 ***

Sorry, BZ was playing tricks on me.
It gave me the impression the bug didn't get created so I submitted again.

Note You need to log in before you can comment on or make changes to this bug.