Bug 881515 - python-novaclient needs Requires: python-iso8601
python-novaclient needs Requires: python-iso8601
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-novaclient (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
:
: 881534 891392 904096 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-28 21:44 EST by Andrew Beekhof
Modified: 2013-03-24 14:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-18 01:52:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Beekhof 2012-11-28 21:44:04 EST
Description of problem:

Missing dependancy on fedora-18 leading to python exception

Version-Release number of selected component (if applicable):

python-novaclient.noarch 1:2.9.0-1.fc18 

How reproducible:

Every time

Steps to Reproduce:
1. yum install python-novaclient
2. nova list
3.
  
Actual results:

[root@fedora-18-base ~]# nova list
Traceback (most recent call last):
  File "/bin/nova", line 9, in <module>
    load_entry_point('python-novaclient==2.9.0', 'console_scripts', 'nova')()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 337, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2311, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2017, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.7/site-packages/novaclient/shell.py", line 36, in <module>
    from novaclient.v1_1 import shell as shell_v1_1
  File "/usr/lib/python2.7/site-packages/novaclient/v1_1/shell.py", line 27, in <module>
    from novaclient.openstack.common import timeutils
  File "/usr/lib/python2.7/site-packages/novaclient/openstack/common/timeutils.py", line 25, in <module>
    import iso8601
ImportError: No module named iso8601

Expected results:

[root@fedora-18-base ~]# nova list
ERROR: You must provide a username via either --os-username or env[OS_USERNAME]

Additional info:

Works after installing python-iso8601.noarch 0:0.1.4-5.fc18
Comment 2 Alan Pevec 2012-11-29 04:52:16 EST
*** Bug 881534 has been marked as a duplicate of this bug. ***
Comment 3 Pádraig Brady 2013-01-02 14:45:50 EST
*** Bug 891392 has been marked as a duplicate of this bug. ***
Comment 4 Alan Pevec 2013-01-25 08:30:37 EST
*** Bug 904096 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-01-30 13:51:35 EST
python-novaclient-2.10.0-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-novaclient-2.10.0-2.fc18
Comment 6 Fedora Update System 2013-02-01 11:58:29 EST
Package python-novaclient-2.10.0-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-novaclient-2.10.0-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1737/python-novaclient-2.10.0-2.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-02-18 01:52:23 EST
python-novaclient-2.10.0-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-03-05 05:34:21 EST
python-novaclient-2.10.0-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-novaclient-2.10.0-2.el6
Comment 9 Fedora Update System 2013-03-24 14:04:32 EDT
python-novaclient-2.10.0-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.