Bug 881824 - anaconda: stop creating /etc/sysconfig/{i18n,keyboard}
anaconda: stop creating /etc/sysconfig/{i18n,keyboard}
Status: CLOSED DUPLICATE of bug 871543
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 881785
  Show dependency treegraph
 
Reported: 2012-11-29 11:16 EST by Michal Schmidt
Modified: 2012-11-29 11:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 11:41:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2012-11-29 11:16:29 EST
We're trying to migrate all packages away from /etc/sysconfig/i18n, /etc/sysconfig/keyboard, and using of HOSTNAME= in /etc/sysconfig/network. See tracker bug 881785 for more details.

Looking at the sources, it appears that Anaconda writes to both the old sysconfig files and to the new systemd-supported config files in:
 pyanaconda/keyboard.py
 pyanaconda/localization.py

We're trying to migrate what we can to use the new config files for F18, because the current situation with the two sets of config files is already buggy, inconsistent and confusing.

I can understand if Anaconda is being extra careful and wants to keep writing both sets of files for F18. However, there's a %post scripts in systemd that deletes the old config files, so writing them seems pointless.
Comment 1 Brian Lane 2012-11-29 11:41:46 EST

*** This bug has been marked as a duplicate of bug 871543 ***

Note You need to log in before you can comment on or make changes to this bug.