Bug 871543 - update for sysconfig changes (systemd >= 195)
update for sysconfig changes (systemd >= 195)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
: 881824 (view as bug list)
Depends On: 870805
Blocks: 871542 881785
  Show dependency treegraph
 
Reported: 2012-10-30 12:41 EDT by Brian Lane
Modified: 2012-12-06 02:28 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 870805
Environment:
Last Closed: 2012-12-06 02:28:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2012-10-30 12:41:42 EDT
+++ This bug was initially created as a clone of Bug #870805 +++

http://lists.fedoraproject.org/pipermail/test/2012-October/111230.html

Anaconda needs to be updated for the changes described above. It currently writes to /etc/sysconfig/i18n and /etc/sysconfig/keyboard
Comment 1 Brian Lane 2012-11-29 11:41:46 EST
*** Bug 881824 has been marked as a duplicate of this bug. ***
Comment 2 Michal Schmidt 2012-11-30 19:10:18 EST
Also Anaconda currently writes HOSTNAME=... in /etc/sysconfig/network and not /etc/hostname.
Comment 3 Michal Schmidt 2012-12-04 08:32:22 EST
I posted a small patchset for this bug to the mailing list:

https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-December/002325.html
Comment 4 Fedora Update System 2012-12-04 19:56:41 EST
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.35-1.fc18
Comment 5 Fedora Update System 2012-12-05 18:12:49 EST
Package pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.22-1.fc18 anaconda-18.35-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.35-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-12-06 02:28:43 EST
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.