Bug 882174 - rhn-client-tools: migration to /etc/hostname, /etc/vconsole.conf, /etc/locale.conf
rhn-client-tools: migration to /etc/hostname, /etc/vconsole.conf, /etc/locale...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
: 951614 (view as bug list)
Depends On:
Blocks: 881785 885219 space19
  Show dependency treegraph
 
Reported: 2012-11-30 05:34 EST by Kay Sievers
Modified: 2013-04-15 03:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 885219 (view as bug list)
Environment:
Last Closed: 2013-03-06 13:35:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kay Sievers 2012-11-30 05:34:00 EST
Fedora is migrating away from:
 /etc/sysconfig/network (the HOSTNAME=... setting)
 /etc/sysconfig/keyboard
 /etc/sysconfig/i18n
to:
 /etc/hostname
 /etc/vconsole.conf
 /etc/locale.conf

See the tracker bug 881785 for details.

We found:
 networkinfo = open("/etc/sysconfig/network", "r").readlines()

Please update the package for the new config files.

The old files are converted and deleted from the system at update time.
If reading the old files is still supported, please make sure they are
never created again.

Thanks!
Comment 1 Miroslav Suchý 2012-11-30 07:21:57 EST
Forwarded to upstream.
Comment 2 Milan Zazrivec 2012-12-07 11:14:06 EST
spacewalk.git master: 54051af0f52cccac8823495e8e3b27029532f97a
Comment 3 Stephen Herr 2013-03-01 12:07:54 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 4 Stephen Herr 2013-03-06 13:35:32 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19
Comment 5 Jan Pazdziora 2013-04-15 03:06:59 EDT
*** Bug 951614 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.