Bug 951614 - on RHEL hostname in /etc/sysconfig/network is an override, in recent Fedoras same should apply for what is in /etc/hostname
on RHEL hostname in /etc/sysconfig/network is an override, in recent Fedoras ...
Status: CLOSED DUPLICATE of bug 882174
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.8
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2013-04-12 11:02 EDT by Jan Hutař
Modified: 2017-09-28 14:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-15 03:06:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-04-12 11:02:16 EDT
Description of problem:
When I specify hostname in /etc/hostname which is different than hostname registration code detects it should be used (same as /etc/sysconfig/network in RHEL).


Version-Release number of selected component (if applicable):
rhn-client-tools-1.6.46-2.fc17.noarch
rhnlib-2.5.49-2.fc17.noarch


How reproducible:
always


Steps to Reproduce:
1. Set hostname to something != your fqdn in /etc/hostname and use `hostname` command to set that hostname in your shell
2. Run rhn-profile-sync and make sure your hostname in RHN Satellite changes


Actual results:
I still see mine fqdn instead of string set in /etc/hostname returned by client.system.getNetwork()['hostname']


Expected results:
Hostname should be set to what is in /etc/hostname


Additional info:
This behavior is in due to bug 457953.
Comment 1 Jan Pazdziora 2013-04-15 03:03:28 EDT
Okay, so: it's not `hostname`, it just running hostname.

And, it's not just running hostname, it's running hostname with a parameter. So, kinda like

  hostname `cat /etc/hostname`
Comment 2 Jan Pazdziora 2013-04-15 03:06:59 EDT

*** This bug has been marked as a duplicate of bug 882174 ***
Comment 3 Eric Herget 2017-09-28 14:07:08 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.