Bug 882241 - livecd-tools: migration to /etc/hostname, /etc/vconsole.conf, /etc/locale.conf
livecd-tools: migration to /etc/hostname, /etc/vconsole.conf, /etc/locale.conf
Status: CLOSED DUPLICATE of bug 870805
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 881785
  Show dependency treegraph
 
Reported: 2012-11-30 08:35 EST by Kay Sievers
Modified: 2012-12-03 11:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 11:56:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kay Sievers 2012-11-30 08:35:32 EST
Fedora is migrating away from:
 /etc/sysconfig/network (the HOSTNAME=... setting)
 /etc/sysconfig/keyboard
 /etc/sysconfig/i18n
to:
 /etc/hostname
 /etc/vconsole.conf
 /etc/locale.conf

See the tracker bug 881785 for details.

We found at least:
 kickstart.py:        f = open(self.path("/etc/sysconfig/i18n"), "w+")

Please update the package for the new config files.

The old files are converted and deleted from the system at update time.
If reading the old files is still supported, please make sure they are
never created again.

Thanks!
Comment 1 Brian Lane 2012-12-03 11:56:26 EST

*** This bug has been marked as a duplicate of bug 870805 ***

Note You need to log in before you can comment on or make changes to this bug.