Bug 870805 - imgcreate needs update for sysconfig changes (systemd >= 195)
imgcreate needs update for sysconfig changes (systemd >= 195)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
: 882241 882242 (view as bug list)
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept 871542 871543 881785
  Show dependency treegraph
 
Reported: 2012-10-28 17:01 EDT by Daniel Drake
Modified: 2012-12-18 01:56 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 871542 871543 (view as bug list)
Environment:
Last Closed: 2012-12-18 01:56:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Drake 2012-10-28 17:01:31 EDT
http://lists.fedoraproject.org/pipermail/test/2012-October/111230.html

imgcreate needs to be updated for the changes described above. It currently writes to /etc/sysconfig/clock, /etc/sysconfig/i18n and /etc/sysconfig/network
Comment 1 Mads Kiilerich 2012-11-29 15:22:13 EST
I was hit by this one.

imgcreate/kickstart.py should create /etc/hostname instead of setting HOSTNAME in /etc/sysconfig/network .

That way hostname would be set early in the boot process, and not later on while gdm is starting and getting confused by the hostname change.

python-imgcreate-18.12-2.fc18.x86_64
Comment 2 Mads Kiilerich 2012-11-30 08:08:51 EST
It turns out that systemd reads /etc/sysconfig/network too, so my problem wasn't caused by this, only confused by it ;-)
Comment 3 Brian Lane 2012-12-03 11:56:26 EST
*** Bug 882241 has been marked as a duplicate of this bug. ***
Comment 4 Brian Lane 2012-12-03 11:56:56 EST
*** Bug 882242 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-12-04 18:43:57 EST
livecd-tools-18.13-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/livecd-tools-18.13-1.fc18
Comment 6 Fedora Update System 2012-12-05 18:10:23 EST
Package livecd-tools-18.13-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-18.13-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19802/livecd-tools-18.13-1.fc18
then log in and leave karma (feedback).
Comment 7 Adam Williamson 2012-12-13 16:44:34 EST
This seems like the best candidate for NTH status to get this used for Final?
Comment 8 Fedora Update System 2012-12-14 19:49:10 EST
livecd-tools-18.14-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/livecd-tools-18.14-1.fc18
Comment 9 Fedora Update System 2012-12-18 01:56:14 EST
livecd-tools-18.14-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.