Bug 882351 - SystemError: (32, 'umount: /run/install/isodir: target is busy.\n (In some cases useful info about processes that use\n the device is found by lsof(8) or fuser(1))')
SystemError: (32, 'umount: /run/install/isodir: target is busy.\n (In ...
Status: CLOSED DUPLICATE of bug 879610
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:dd3f72e880c6782a3e21f40530a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-30 13:14 EST by Michael Schwendt
Modified: 2012-12-05 11:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-05 11:05:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: ifcfg.log (2.21 KB, text/plain)
2012-11-30 13:14 EST, Michael Schwendt
no flags Details
File: anaconda-tb (784.88 KB, text/plain)
2012-11-30 13:14 EST, Michael Schwendt
no flags Details
File: product (6 bytes, text/plain)
2012-11-30 13:14 EST, Michael Schwendt
no flags Details
File: type (9 bytes, text/plain)
2012-11-30 13:14 EST, Michael Schwendt
no flags Details
File: environ (845 bytes, text/plain)
2012-11-30 13:14 EST, Michael Schwendt
no flags Details

  None (edit)
Description Michael Schwendt 2012-11-30 13:14:32 EST
Version-Release number of selected component:
anaconda-18.29.2

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.6-3.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.29.2 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/isys/__init__.py", line 152, in umount
:    rc = _isys.umount(what)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 656, in unmount
:    rc = isys.umount(self._mountpoint, removeDir = False)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 863, in teardown
:    return self.unmount(*args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 740, in _preTeardown
:    self.originalFormat.teardown()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 755, in teardown
:    if not self._preTeardown(recursive=recursive):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1969, in teardownAll
:    device.teardown(recursive=True)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1963, in _populate
:    self.teardownAll()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1846, in populate
:    self._populate()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2088, in on_unlock_clicked
:    self.__storage.devicetree.populate()
:SystemError: (32, 'umount: /run/install/isodir: target is busy.\n        (In some cases useful info about processes that use\n         the device is found by lsof(8) or fuser(1))')
Comment 1 Michael Schwendt 2012-11-30 13:14:37 EST
Created attachment 655170 [details]
File: ifcfg.log
Comment 2 Michael Schwendt 2012-11-30 13:14:49 EST
Created attachment 655171 [details]
File: anaconda-tb
Comment 3 Michael Schwendt 2012-11-30 13:14:55 EST
Created attachment 655172 [details]
File: product
Comment 4 Michael Schwendt 2012-11-30 13:14:57 EST
Created attachment 655173 [details]
File: type
Comment 5 Michael Schwendt 2012-11-30 13:14:59 EST
Created attachment 655174 [details]
File: environ
Comment 6 Michael Schwendt 2012-11-30 13:56:43 EST
How to reproduce:

1. enter "Manual Partitioning" screen
2. unfold an old installation tree to reuse its Root
3. enter "/" as mount-point, enable the "Reformat" checkbox, then click "Apply Changes"
4. leave screen with "Finish Partitioning"

So far so good.

5. revisit "Manual Partitioning" screen
6. unfold "Unknown" storage entries
7. select my LUKS encrypted logical volume to be mounted as /home
8. enter secondary passphrase, click "Unlock"

Crash.

Important: Order does matter. Getting access to the LUKS /home _before_ adding the Root mount-point does not crash, but causes the other show-stopper I discuss on test list.


Package: anaconda-18.29.2
OS Release: Fedora release 18-Beta
Comment 7 Michael Schwendt 2012-11-30 14:05:15 EST
Since the crash refers to /run/install/isodir it smells much as if one can replace steps 5-8 with just

5. revisit "Manual Partitioning" screen and leave it with "Finish Partitioning"

but I haven't tried that yet.
Comment 8 David Lehman 2012-11-30 17:03:17 EST
This is specific to media on local storage. We need something to skip teardown of the media source device.
Comment 9 Chris Lumens 2012-12-05 11:05:00 EST

*** This bug has been marked as a duplicate of bug 879610 ***

Note You need to log in before you can comment on or make changes to this bug.