Bug 879610 - SystemError: (32, 'umount: /run/install/isodir: target is busy.\n (In some cases useful info about processes that use\n the device is found by lsof(8) or fuser(1))')
SystemError: (32, 'umount: /run/install/isodir: target is busy.\n (In ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:5c6268e7ae873779962c1f953ef...
:
: 882351 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-11-23 07:38 EST by Kamil Páral
Modified: 2012-12-07 23:30 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-18.36-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-07 23:30:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (203.21 KB, text/plain)
2012-11-23 07:38 EST, Kamil Páral
no flags Details
File: product (6 bytes, text/plain)
2012-11-23 07:38 EST, Kamil Páral
no flags Details
File: type (9 bytes, text/plain)
2012-11-23 07:38 EST, Kamil Páral
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-11-23 07:38 EST, Kamil Páral
no flags Details
File: storage.log (71.43 KB, text/plain)
2012-11-23 07:39 EST, Kamil Páral
no flags Details
File: version (7 bytes, text/plain)
2012-11-23 07:39 EST, Kamil Páral
no flags Details
File: environ (780 bytes, text/plain)
2012-11-23 07:39 EST, Kamil Páral
no flags Details
File: executable (14 bytes, text/plain)
2012-11-23 07:39 EST, Kamil Páral
no flags Details
File: anaconda.log (9.66 KB, text/plain)
2012-11-23 07:39 EST, Kamil Páral
no flags Details
File: syslog (61.21 KB, text/plain)
2012-11-23 07:39 EST, Kamil Páral
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-23 07:39 EST, Kamil Páral
no flags Details
File: packaging.log (4.71 KB, text/plain)
2012-11-23 07:39 EST, Kamil Páral
no flags Details
File: cmdline_file (90 bytes, text/plain)
2012-11-23 07:39 EST, Kamil Páral
no flags Details
File: release (24 bytes, text/plain)
2012-11-23 07:39 EST, Kamil Páral
no flags Details
File: program.log (25.77 KB, text/plain)
2012-11-23 07:39 EST, Kamil Páral
no flags Details
18.35 anaconda-tb (397.14 KB, text/plain)
2012-12-05 04:54 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-11-23 07:38:49 EST
Description of problem:
This happened when I tried to verify bug 876897. I booted netinst and hand-selected dvd.iso on a local partition. I got this traceback during "Preparing to install".

Version-Release number of selected component:
anaconda-18.29.2

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.6-3.fc18.i686

description:
:The following was filed automatically by anaconda:
:anaconda 18.29.2 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/isys/__init__.py", line 152, in umount
:    rc = _isys.umount(what)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 656, in unmount
:    rc = isys.umount(self._mountpoint, removeDir = False)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 863, in teardown
:    return self.unmount(*args, **kwargs)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 743, in _preTeardown
:    self.format.teardown()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 755, in teardown
:    if not self._preTeardown(recursive=recursive):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1969, in teardownAll
:    device.teardown(recursive=True)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 165, in turnOnFilesystems
:    storage.devicetree.teardownAll()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/install.py", line 113, in doInstall
:    turnOnFilesystems(storage)
:  File "/usr/lib/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:SystemError: (32, 'umount: /run/install/isodir: target is busy.\n        (In some cases useful info about processes that use\n         the device is found by lsof(8) or fuser(1))')
Comment 1 Kamil Páral 2012-11-23 07:38:52 EST
Created attachment 650396 [details]
File: anaconda-tb
Comment 2 Kamil Páral 2012-11-23 07:38:54 EST
Created attachment 650397 [details]
File: product
Comment 3 Kamil Páral 2012-11-23 07:38:56 EST
Created attachment 650398 [details]
File: type
Comment 4 Kamil Páral 2012-11-23 07:38:58 EST
Created attachment 650399 [details]
File: ifcfg.log
Comment 5 Kamil Páral 2012-11-23 07:39:00 EST
Created attachment 650400 [details]
File: storage.log
Comment 6 Kamil Páral 2012-11-23 07:39:02 EST
Created attachment 650401 [details]
File: version
Comment 7 Kamil Páral 2012-11-23 07:39:04 EST
Created attachment 650402 [details]
File: environ
Comment 8 Kamil Páral 2012-11-23 07:39:06 EST
Created attachment 650403 [details]
File: executable
Comment 9 Kamil Páral 2012-11-23 07:39:08 EST
Created attachment 650404 [details]
File: anaconda.log
Comment 10 Kamil Páral 2012-11-23 07:39:11 EST
Created attachment 650405 [details]
File: syslog
Comment 11 Kamil Páral 2012-11-23 07:39:13 EST
Created attachment 650406 [details]
File: hashmarkername
Comment 12 Kamil Páral 2012-11-23 07:39:15 EST
Created attachment 650407 [details]
File: packaging.log
Comment 13 Kamil Páral 2012-11-23 07:39:16 EST
Created attachment 650408 [details]
File: cmdline_file
Comment 14 Kamil Páral 2012-11-23 07:39:18 EST
Created attachment 650409 [details]
File: release
Comment 15 Kamil Páral 2012-11-23 07:39:21 EST
Created attachment 650410 [details]
File: program.log
Comment 16 Kamil Páral 2012-11-23 07:51:34 EST
 The installer must be able to use all supported local and remote package source options 
https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
Comment 17 Adam Williamson 2012-11-29 14:32:14 EST
Discussed at 2012-11-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-29/f18final-blocker-review-1.1.2012-11-29-17.01.log.txt . Accepted as a blocker per criterion cited in comment #16.
Comment 18 Kamil Páral 2012-11-30 04:36:00 EST
I did the same procedure as in bug 882147, but this time I was very careful not to touch existing vda1. I used manual partitioning to create the layout and left vda1 unchanged. It crashed in "Preparing to install".

Package: anaconda-18.29.2
OS Release: Fedora release 18-Beta
Comment 19 A.J. Werkman 2012-11-30 08:31:04 EST
Isn't this the same as bug #855513?
Comment 20 Michael Schwendt 2012-11-30 15:22:38 EST
Customized the installation and manual partitioning as far as possible _without_ unlocking my LUKS encrypted /home volume, which crashes as reported before. Then clicked "Begin Installation". Immediately got this crash also related to the isodir. Something is terribly wrong there.

Package: anaconda-18.29.2
Architecture: x86_64
OS Release: Fedora release 18-Beta
Comment 21 Adam Williamson 2012-11-30 23:01:48 EST
For those reporting dupes, check that your error is actually the same as the one in the subject - I've noticed libreport is a bit over-enthusiastic about duping bugs with umount error messages.
Comment 22 Michael Schwendt 2012-12-01 06:09:14 EST
Well, that implies that if one reports a crash from within Anaconda, one loses the backtrace if one doesn't save a backup of it manually.
Comment 23 Adam Williamson 2012-12-01 13:29:13 EST
yes, which is a shame. we've kicked around the idea of asking for libreport to grow an option to report the tb even if the bug is a dupe, but the problem with that is you'd wind up with people checking it all the time, and we don't want that...
Comment 24 Chris Lumens 2012-12-03 14:30:58 EST
I can't reproduce this with anaconda from git plus my patch for bug 879142.  Perhaps there's the difference.  In the original report, did you perhaps visit storage first?
Comment 25 Kamil Páral 2012-12-03 15:01:04 EST
(In reply to comment #24)
That's very possible. Can't you tell from the logs? I really don't remember. I can try to reproduce if necessary. Just tell me which anaconda version to try.
Comment 26 Chris Lumens 2012-12-04 16:57:15 EST
I've tried a couple different ways to reproduce this, but no luck.  If you can please test again with a tree containing anaconda-18.34-1 or later (so, some post-beta tree) and attach detailed reproducer steps, it would really help move this bug along.  Thanks.
Comment 27 Kamil Páral 2012-12-05 04:52:46 EST
Trying to verify bug 879610. I have 5GB vda1 partition with dvd.iso on it. I have 6 GB of free space after it. I booted netinst and hand-selected dvd.iso as installation source. In the partitioning I was told I have plenty of space to install Fedora, so I just hit Continue (no reclaiming space, no manual partitioning, nothing). Crashed during Preparing to install.

Package: anaconda-18.35
Architecture: x86_64
OS Release: Fedora release 18
Comment 28 Kamil Páral 2012-12-05 04:54:06 EST
Created attachment 658107 [details]
18.35 anaconda-tb
Comment 29 Chris Lumens 2012-12-05 11:05:00 EST
*** Bug 882351 has been marked as a duplicate of this bug. ***
Comment 30 Fedora Update System 2012-12-05 20:55:21 EST
anaconda-18.36-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.36-1.fc18
Comment 31 Kamil Páral 2012-12-06 05:53:16 EST
This is fixed in anaconda 18.36. I tried both manual picking of dvd.iso and booting with inst.repo=hd:vda1:/dvd.iso.
Comment 32 Fedora Update System 2012-12-07 23:30:44 EST
anaconda-18.36-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.