Bug 882634 - RuntimeError: Error running systemctl: Cannot allocate memory
RuntimeError: Error running systemctl: Cannot allocate memory
Status: CLOSED DUPLICATE of bug 873343
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:58b212d666537bf59df21269cd7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-02 07:30 EST by Niki Guldbrand
Modified: 2012-12-03 10:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 10:19:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (240.76 KB, text/plain)
2012-12-02 07:30 EST, Niki Guldbrand
no flags Details
File: product (6 bytes, text/plain)
2012-12-02 07:30 EST, Niki Guldbrand
no flags Details
File: type (9 bytes, text/plain)
2012-12-02 07:30 EST, Niki Guldbrand
no flags Details
File: ifcfg.log (2.50 KB, text/plain)
2012-12-02 07:30 EST, Niki Guldbrand
no flags Details
File: storage.log (36.57 KB, text/plain)
2012-12-02 07:30 EST, Niki Guldbrand
no flags Details
File: version (7 bytes, text/plain)
2012-12-02 07:31 EST, Niki Guldbrand
no flags Details
File: environ (781 bytes, text/plain)
2012-12-02 07:31 EST, Niki Guldbrand
no flags Details
File: executable (14 bytes, text/plain)
2012-12-02 07:31 EST, Niki Guldbrand
no flags Details
File: anaconda.log (7.03 KB, text/plain)
2012-12-02 07:31 EST, Niki Guldbrand
no flags Details
File: syslog (184.45 KB, text/plain)
2012-12-02 07:31 EST, Niki Guldbrand
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-12-02 07:31 EST, Niki Guldbrand
no flags Details
File: packaging.log (2.52 KB, text/plain)
2012-12-02 07:32 EST, Niki Guldbrand
no flags Details
File: cmdline_file (92 bytes, text/plain)
2012-12-02 07:32 EST, Niki Guldbrand
no flags Details
File: release (24 bytes, text/plain)
2012-12-02 07:32 EST, Niki Guldbrand
no flags Details
File: program.log (19.72 KB, text/plain)
2012-12-02 07:32 EST, Niki Guldbrand
no flags Details

  None (edit)
Description Niki Guldbrand 2012-12-02 07:30:11 EST
Description of problem:
Trying to install F18 Beta DVD iso in a virtual machine with 512M ram (which anaconda said was the minimum required), first (and only thing I managed to complete) i configured the timezone information and added a couple of local time servers on my lan, and it crasted when I had finished that.

Version-Release number of selected component:
anaconda-18.29.2

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.6-3.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.29.2 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 193, in execWithRedirect
:    raise RuntimeError, errstr
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 1019, in _run_systemctl
:    stdout="/dev/tty5", stderr="/dev/tty5")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 1030, in restart_service
:    return _run_systemctl("restart", service)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/datetime_spoke.py", line 156, in run
:    iutil.restart_service("chronyd")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/datetime_spoke.py", line 848, in on_ntp_config_clicked
:    response = self._config_dialog.run()
:RuntimeError: Error running systemctl: Cannot allocate memory
Comment 1 Niki Guldbrand 2012-12-02 07:30:40 EST
Created attachment 655939 [details]
File: anaconda-tb
Comment 2 Niki Guldbrand 2012-12-02 07:30:44 EST
Created attachment 655940 [details]
File: product
Comment 3 Niki Guldbrand 2012-12-02 07:30:47 EST
Created attachment 655943 [details]
File: type
Comment 4 Niki Guldbrand 2012-12-02 07:30:50 EST
Created attachment 655946 [details]
File: ifcfg.log
Comment 5 Niki Guldbrand 2012-12-02 07:30:55 EST
Created attachment 655951 [details]
File: storage.log
Comment 6 Niki Guldbrand 2012-12-02 07:31:00 EST
Created attachment 655955 [details]
File: version
Comment 7 Niki Guldbrand 2012-12-02 07:31:04 EST
Created attachment 655960 [details]
File: environ
Comment 8 Niki Guldbrand 2012-12-02 07:31:07 EST
Created attachment 655963 [details]
File: executable
Comment 9 Niki Guldbrand 2012-12-02 07:31:10 EST
Created attachment 655967 [details]
File: anaconda.log
Comment 10 Niki Guldbrand 2012-12-02 07:31:38 EST
Created attachment 655969 [details]
File: syslog
Comment 11 Niki Guldbrand 2012-12-02 07:31:52 EST
Created attachment 655970 [details]
File: hashmarkername
Comment 12 Niki Guldbrand 2012-12-02 07:32:49 EST
Created attachment 655971 [details]
File: packaging.log
Comment 13 Niki Guldbrand 2012-12-02 07:32:52 EST
Created attachment 655972 [details]
File: cmdline_file
Comment 14 Niki Guldbrand 2012-12-02 07:32:54 EST
Created attachment 655973 [details]
File: release
Comment 15 Niki Guldbrand 2012-12-02 07:32:59 EST
Created attachment 655974 [details]
File: program.log
Comment 16 Chris Lumens 2012-12-03 10:19:49 EST
Yeah, these memory figures need to be revisited.

*** This bug has been marked as a duplicate of bug 873343 ***

Note You need to log in before you can comment on or make changes to this bug.