Bug 873343 - Cannot install with 1 GB of RAM
Cannot install with 1 GB of RAM
Status: CLOSED DUPLICATE of bug 875418
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 882634 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-05 10:33 EST by Jean-François Fortin Tam
Modified: 2012-12-10 11:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 11:08:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jean-François Fortin Tam 2012-11-05 10:33:38 EST
Using a liveUSB (with two different USB keys) of the F18 alpha (don't have the beta to test with yet), I'm pretty much unable to install. As far as I can tell, gnome-shell+anaconda make the system eventually enter a kernel death swap scenario, which is lashed out onto the USB key (from what I see with the activity LED).

I tested with:
- a Zotac zbox
- an HP mini 1000 netbook
Both of which have Intel graphics and 1 GB of RAM.

In the first case, I spent litterally one or two hours *trying* to do manual partitioning. Every operation with the UI was sluggish and hammered the USB key with I/O for minutes at a time (ie: it would take minutes between the time you click the + button and the time you get a dialog to set the mountpoint and size).

In the second case, I didn't want to have the same experience, so I just requested fully automatic partitioning without review. The installation started (as far as I could tell with "top", it was using rsync in the background) and it took maybe two hours to install, instead of 10-20 minutes as I would expect (looking at top, I saw that at some point the kswapd was using a LOT of CPU).



There are *many* netbooks or business desktop computers out there running with 1 GB of RAM. It worked fine with previous Fedora versions.

Fedora's official system requirements are: "At least 768 MiB of RAM, 1 GiB recommended for better performance".
Comment 1 Steve Tyler 2012-11-13 01:22:50 EST
Based on tests in a VM, 1 GB should be plenty of memory to install from a Live CD image: Bug 875418, Comment 6.

That test was with Fedora-18-Beta-TC8-x86_64-Live-Desktop.iso:
http://dl.fedoraproject.org/pub/alt/stage/

A BZ search for kswapd found this:
Bug 866988 - kswapd using 100%cpu for extended period on i686 kvm vhost - rawhide
Comment 2 Steve Tyler 2012-11-13 13:56:23 EST
I cannot reproduce the problems reported in Comment 0 on a bare metal system with 1 GB memory using Fedora-18-Beta-TC8-i686-Live-Desktop.iso installed on a USB stick.

Test procedure:

Install Live CD image to 8 GB USB stick:

$ sudo livecd-iso-to-disk --format --reset-mbr Fedora-18-Beta-TC8-i686-Live-Desktop.iso /dev/sdc

Boot from USB stick.

Top shows 1011296 KiB Mem.

The installer starts, and the user interface is responsive. I did not attempt to actually install.
Comment 3 Jean-François Fortin Tam 2012-11-13 21:25:16 EST
I downloaded and tested the Beta TC8 iso now. Good news! The system's overall memory usage and responsiveness improved drastically:


# Alpha
- before starting anaconda: 467 MiB of 985.3 MiB, 0 swap out of 1.9 GiB (measurements from gnome-system-monitor)
- launch anaconda: swap space gets disabled, mem usage climbs to 501 MiB
- select language, keyboard layout, timezone, climbs to ~515-520 Mib
- start the partitioning tool (after selecting the target disk)... memory usage jumps to 595 MiB when you get to the "would you like to autopartition or manually?" dialog, and stays at that level throughout partitioning.
- installing: not tested.

# Beta TC8
- before starting anaconda: 215 MiB (way better!)
- launch anaconda: swap space gets disabled, memory usage climbs to 265 MiB
- language, keyboard layout, timezone: mem usage climbs to 283 Mib
- accessing the disk partitioning tool: 348 MiB
- installing: could not test because of (already reported) bugs

I could not actually test that it installs fine, but at least it's a step forward. Should this be kept open for retesting when the beta comes out?
Comment 4 Steve Tyler 2012-11-14 00:52:47 EST
Thanks for your detailed comparative report. That is a significant reduction in memory usage.

Quoting Jesse in Bug 875418, Comment 5:

"With F18 and the rewrite we aren't really sure what our memory requirements are, and what is a bug of too much in use vs this is what we need."

So retesting is going to be needed ...
Comment 5 Chris Lumens 2012-12-03 10:19:49 EST
*** Bug 882634 has been marked as a duplicate of this bug. ***
Comment 6 Chris Lumens 2012-12-10 11:08:11 EST
I believe everything here is being tracked by bug 875418 as well, and that bug is even being actively worked on and commented in.  I'm going to dup this one to there, which also shows the current status.  Thanks for the report.

*** This bug has been marked as a duplicate of bug 875418 ***

Note You need to log in before you can comment on or make changes to this bug.