Bug 882718 - PRD32 - [engine-core] removal of calls to updateVmInSpm/removeVmInSpm - introduce of OvfAutoUpdater
PRD32 - [engine-core] removal of calls to updateVmInSpm/removeVmInSpm - intro...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.2.0
Assigned To: Liron Aravot
Leonid Natapov
http://www.ovirt.org/Feature/OvfAutoU...
storage
:
: 875452 878894 (view as bug list)
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-12-02 16:57 EST by Liron Aravot
Modified: 2016-02-10 11:38 EST (History)
12 users (show)

See Also:
Fixed In Version: sf3
Doc Type: Enhancement
Doc Text:
Feature: removal of calls to updateVmInSpm/removeVmInSpm - introduce of OvfAutoUpdater Reason: vm/template configurations (including disks info) are stored on the master storage domain for backup purposes and also to provide the abillity to run VMs without having a running engine/db. Currently ovf update is done synchronously when performing various operations on vms/templates - update, save, adding/removing a disk, etc. What's more, currently updating the ovf (updateVM vdsm call) is usually done within a transcation. The idea behined OvfAutoUpdater is to perform a batch ovf update operations that aggregate all hanging updates per data center. These updates will be done in specifed time intervals which will reduce XML-RPC calls and will enable the removal of this syncronous vdsm call from all over the code.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liron Aravot 2012-12-02 16:57:22 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Haim 2012-12-17 03:25:10 EST
removing QA_ACK till full information on this PRD is added by developer or PM.
wiki page is fine as well.
Comment 4 Liron Aravot 2012-12-17 07:18:53 EST
wiki page:
http://www.ovirt.org/Feature/OvfAutoUpdater

patch:
http://gerrit.ovirt.org/#/c/9328/
Comment 5 Ayal Baron 2012-12-26 01:42:18 EST
*** Bug 875452 has been marked as a duplicate of this bug. ***
Comment 6 Ayal Baron 2012-12-26 05:59:37 EST
*** Bug 878894 has been marked as a duplicate of this bug. ***
Comment 7 Liron Aravot 2012-12-30 10:32:59 EST
merged upstream
Comment 8 Itamar Heim 2013-06-11 04:32:30 EDT
3.2 has been released
Comment 9 Itamar Heim 2013-06-11 04:32:32 EDT
3.2 has been released
Comment 10 Itamar Heim 2013-06-11 04:33:34 EDT
3.2 has been released
Comment 11 Itamar Heim 2013-06-11 04:42:02 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.