Bug 88273 - Running 'rpm --rebuild' produces db4 error
Running 'rpm --rebuild' produces db4 error
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-08 10:52 EDT by Jon Hart
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-17 11:22:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of 'rpm -vv --rebuilddb' (53.11 KB, application/octet-stream)
2003-04-08 10:56 EDT, Jon Hart
no flags Details

  None (edit)
Description Jon Hart 2003-04-08 10:52:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Summary:
========
Running "rpm --rebuild" generates the following message:
'error: db4 error(16) from dbenv->remove: Device or resource busy'

Background:
============
This bug report was generated at the request of Red Hat support engineer, Paulo
Ng. Please refer to Service Request 232865.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in as root
2. Run 'rpm --rebuilddb'
3.
    

Actual Results:  Relevant output from 'rpm -vv --rebuilddb':
===========================================
D: closed   db environment /var/lib/rpm/Packages
error: db4 error(16) from dbenv->remove: Device or resource busy
D: removed  db environment /var/lib/rpm/Packages


Expected Results:  No db4 errors

Additional info:

Please refer to Service Request 232865. Contact Red Hat support engineer, Paulo
Ng. This bug report was created per his request.
Comment 1 Jon Hart 2003-04-08 10:56:33 EDT
Created attachment 91008 [details]
Output of 'rpm -vv --rebuilddb'
Comment 2 Jon Hart 2003-04-08 11:27:00 EDT
BTW, running 'cd /var/lib/rpm && /usr/lib/rpm/rpmdb_verify Packages' produces no
errors. The Packages database (and every other db in /var/lib/rpm) appears to be
fine.
Comment 3 Michael Young 2003-04-08 18:34:51 EDT
Duplicate of bug 83281
Comment 4 Jon Hart 2003-04-09 13:51:47 EDT
Yup, 'tis the same as 83281.  Closing this ticket as duplicate.

*** This bug has been marked as a duplicate of 83281 ***
Comment 5 Jon Hart 2003-04-17 11:14:30 EDT
Jeff Johnson closed 83281 without a proper resolution -- Jeff felt too many
non-related bugs were being dupped to 83281.

This bug (88287) is clearly the same issue as 83281.  Further, rpm/db4/nptl
issues have not be corrected.  Therefore, I am reopening this bug report.
Comment 6 Jeff Johnson 2003-04-17 11:22:20 EDT
Yes, there is an error message displayed after --rebuilddb.

The message is harmless, there is no problem here.

This is a known issue and will be fixed in rpm-4.3.
Comment 7 Adam Monsen 2003-04-17 11:39:49 EDT
Jeff, even though the error message is harmless, people don't /know/ that it is
harmless.

I may be the special case, but before I found bug 83281 I thought the message
declared something extremely wrong and reinstalled Redhat 9. Shouldn't there be
an open bug until the error is fixed and no longer appears?

(At the least, this info should be added to the only FAQ I could find about
safely rebuilding an RPM database, here: http://rpm.org/hintskinks/repairdb/.
I've emailed the editor of the page with the suggestion.)
Comment 8 Jeff Johnson 2003-04-17 11:44:41 EDT
I understand all that. No matter what, this error message is in
already released software, and there are going to be zillions of dupes.

All that can't be helped. If it make you happier to have a bug
for this problem, that's fine. What I can't do is service a zillion
*different* problems in a single bug pile on report, no matter what
problem I solve, some other problem will always remain.

That's the only rationale for closing the bug, to prevent a catch-all
bug pile-on. Feel free to reopen other bugs, or even this bug, and
I'll get to the problem when I get to the problem.
Comment 9 Jon Hart 2003-04-17 12:42:19 EDT
> That's the only rationale for closing the bug,
> to prevent a catch-all bug pile-on. Feel free
> to reopen other bugs, or even this bug, and
> I'll get to the problem when I get to the problem.

Understood. Personally, I prefer to keep 83281 open. 83281 already has a nice
trail... especially with the 'nosysinfo' boot option. Further, although the bug
seems to be harmless, the 'nosysinfo' connection indicates a possible
awkwardness between rpm and the new nptl implementation, two fairly important
components. Therefore, I feel this bug should be treated as a known, unresolved
-- albeit harmless -- issue.

Anyway, if 83281 is reopened, perhaps we could remove dupped bug reports which
do not have clear direct ties to the rpm/db4 issue?

Note You need to log in before you can comment on or make changes to this bug.