Bug 83281 - rpm ---rebuilddb reports db4 error
rpm ---rebuilddb reports db4 error
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
: 84386 (view as bug list)
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-02-01 08:49 EST by Michael Young
Modified: 2007-04-18 12:50 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-17 09:52:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2003-02-01 08:49:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-GB; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
If you run rpm --rebuilddb you get the error
error: db4 error(16) from dbenv->remove: Device or resource busy
though the rebuild process does seem to have done something judging by the file
sizes in /var/lib/rpm
Someone else (on the phoebe list) has seen the same problem, so it isn't just my
database.
Comment 1 Jeff Johnson 2003-02-01 08:54:34 EST
Try
    rm -f /var/lib/rpm/_db*
and then repeat the --rebuilddb command.

If that doesn't fix, please reopen this bug, and include the versions
of rpm, kernel, and glibc currently installed.
Comment 2 Michael Young 2003-02-01 09:07:38 EST
I am pretty sure I have already tried that, but I can't recheck until Monday.
The system was upgraded from 8.0, the kernel would be -2.25, I can't remember
the others, though they will have been updated from rawhide in the past couple
of days.
I will reopen this bug when I can check the details (assuming the problem hasn't
magically gone away).
Comment 3 Thomas J. Baker 2003-02-01 09:16:40 EST
That occured for me too. I'm currently running kernel-2.4.20-2.29,
glibc-2.3.1-38, and rpm-4.2-0.64. Like he said, the db rebuild seemed to go OK. 

I just tried another rebuild:

[tjb@neuromancer rawhide]# rm -f /var/lib/rpm/__db.00*
[tjb@neuromancer rawhide]# rpm --rebuilddb
error: db4 error(16) from dbenv->remove: Device or resource busy
[tjb@neuromancer rawhide]#

Comment 4 Jeff Johnson 2003-02-01 09:21:49 EST
Try running "rpm --rebuilddb -vv". If the error is reported
during close, then the message is harmless (but still needs fixing).
Comment 5 Michael Young 2003-02-03 04:55:15 EST
kernel=2.4.20-2.25 glibc=2.3.1-38 rpm=4.2-0.64

Yes it looks like the error occurs in the close part
...
D: adding 185 entries to Filemd5s index.
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
error: db4 error(16) from dbenv->remove: Device or resource busy
D: removed  db environment /var/lib/rpm/Packages
D: closed   db index       /var/lib/rpmrebuilddb.1094/Pubkeys
D: closed   db index       /var/lib/rpmrebuilddb.1094/Filemd5s
...
Comment 6 Bill Glover 2003-02-12 23:27:05 EST
I found that the same command rpm --rebuilddb was erroring on my test system.

So I just did a fresh install and then auto ... up2date.

tried...
rm -f /var/lib/rpm/_db*
then ...
rpm --rebuilddb, no errors
then ...
rpm --rebuilddb and the same error shows up.
error: db4 error(16) from dbenv->remove: Device or resource busy

There doesn't seem to be anything wrong with the rpm system. just the error
message. 
rpm installs, searches, and removes properly.

the kernel is  ...  kernel-2.4.20-2.24

If you would like me to test anything else please advise.

bill
Comment 7 Daniel Resare 2003-02-16 14:09:52 EST
*** Bug 84386 has been marked as a duplicate of this bug. ***
Comment 8 Michael Young 2003-04-02 11:52:00 EST
Changing version to 9, as the bug is still in the final release (rpm-4.2-0.69)
Comment 9 Marcus Alves Grando 2003-04-03 23:55:23 EST
I Try upgrade rpm packages from ftp.rpm.org, version 4.2-1, but the problem
continue.

When compile kernel 2.5.66 and reboot, rpm not work any option.
When install rpm kernel 2.4.20 from CD installer, the most problem dissaper.

Only problem persist in 2.4.20 is
# rpm --rebuilddb
error: db4 error(16) from dbenv->remove: Device or resource busy
Comment 10 taj 2003-04-05 18:35:53 EST
Clean install, no upgrades rh9 dot oh

...
D: adding "Development/Libraries" to Group index.
D: adding 11 entries to Requirename index.
D: adding 2 entries to Providename index.
D: adding 6 entries to Dirnames index.
D: adding 11 entries to Requireversion index.
D: adding 2 entries to Provideversion index.
D: adding 1 entries to Installtid index.
D: adding 1 entries to Sigmd5 index.
D: adding "f7fc6ad3993d88d3e40419d0c49cbd92839903b6" to Sha1header index.
D: adding 13 entries to Filemd5s index.
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
error: db4 error(16) from dbenv->remove: Device or resource busy
D: removed  db environment /var/lib/rpm/Packages
D: closed   db index       /var/lib/rpmrebuilddb.1918/Pubkeys
D: closed   db index       /var/lib/rpmrebuilddb.1918/Filemd5s
D: closed   db index       /var/lib/rpmrebuilddb.1918/Sha1header
D: closed   db index       /var/lib/rpmrebuilddb.1918/Sigmd5
D: closed   db index       /var/lib/rpmrebuilddb.1918/Installtid
D: closed   db index       /var/lib/rpmrebuilddb.1918/Provideversion
D: closed   db index       /var/lib/rpmrebuilddb.1918/Requireversion
D: closed   db index       /var/lib/rpmrebuilddb.1918/Dirnames
D: closed   db index       /var/lib/rpmrebuilddb.1918/Triggername
D: closed   db index       /var/lib/rpmrebuilddb.1918/Conflictname
D: closed   db index       /var/lib/rpmrebuilddb.1918/Providename
                                                                            
[root@localhost root]# cat /etc/redhat-release
Red Hat Linux release 9 (Shrike)
[root@localhost root]# uname -a
Linux localhost.localdomain 2.4.20-8 #1 Thu Mar 13 17:54:28 EST 2003 i686 i686
i386 GNU/Linux
Comment 11 Marcus Alves Grando 2003-04-05 18:42:08 EST
I solve this...

I Upgrade GLIBC from: ftp://people.redhat.com/jakub/glibc/errata/9/
And install "nptl-devel" too.

After this rpm work normally.
Comment 12 taj 2003-04-06 17:19:33 EDT
The suggested solution in message #11 did not the solve the case in message #10
Comment 13 Barry K. Nathan 2003-04-09 04:09:12 EDT
Marcus, that does not fix it for me either. Nor do the new test-4.2 RPM packages
at ftp.rpm.org (rpm-4.2-1).

What *does* seem to fix the problem for me is booting with "nosysinfo"...
Comment 14 Jon Hart 2003-04-09 13:41:49 EDT
Sorry to butt in. I have a duplicate bug entry (88273).

Booting with the nosysinfo option works for me as well.
Comment 15 Jon Hart 2003-04-09 13:51:59 EDT
*** Bug 88273 has been marked as a duplicate of this bug. ***
Comment 16 Adam Monsen 2003-04-10 14:30:19 EDT
dupes?:
bug #88250
bug #88453
bug #88164
Comment 17 Wolfgang Reimer 2003-04-17 09:09:04 EDT
Clean RedHat 9 install (rpm-4.2-0.69) + all updates available by today,
including kernel-2.4.20-9 and glibc-2.3.2-27.9. Still the same problem.

Executing "rm -f /var/lib/rpm/__db.00*" before executing "rpm
--rebuilddb"(comment #1) does not help.

Booting with "nosysinfo" (comment #13) solved the problem for me, too.
Comment 18 Barry K. Nathan 2003-04-17 09:40:15 EDT
Adam, I don't think those three bugs are dupes of this one. I can't reproduce
those three bugs with the test-4.2 RPMs from ftp.rpm.org; as far as I can tell,
they've been fixed in the test-4.2 packages. However, I can still reproduce this
one at will, as long as I don't use nosysinfo.
Comment 19 Jeff Johnson 2003-04-17 09:52:02 EDT
There are too many descriptions of varying problems here
for me to parse "reproduce this one". Barry: could you open
a different bug and describe your persisting problem? If
just the error message
    error: db4 error(16) from dbenv->remove: Device or resource busy
that's a known (and harmless) error message with --rebuilddb.

Otherwise, I'm gonna close this bug because there's too many
different problems here to sort out. Feel free to reopen other
new bugs if you still have problems.
Comment 20 Jon Hart 2003-04-17 11:24:33 EDT
Jeff, I've reopened bug 88273; 88273 is clearly a dup of this bug.
Comment 21 Adam Monsen 2003-04-17 11:38:48 EDT
Barry,

Yes, I agree, they weren't dupes; I should've said "related?".
Comment 22 Barry K. Nathan 2003-04-17 13:39:05 EDT
Jeff, yes, by "this one" I meant the "known (and harmless)" message.
Comment 23 Michael Young 2003-04-17 16:28:04 EDT
Barry, according to bug 88273 the known, harmless bug will be fixed in rpm 4.3,
which probably means not until RedHat 9.1 or 10 or whatever they choose to call
it. I agree with Jeff that this bug is getting too confused, so I am not going
to reopen it even though the known, harmless bug is still a bug.
Comment 24 Gérard Milmeister 2003-04-20 15:09:59 EDT
Well I just experienced this bug, and a great part of my rpm database is now
missing! So this is by no means a harmless bug. Fortunately I had still a copy
of /var/log/rpmpkgs so I could reenter the missing entries using rpm -i
--justdb, but I don't know if there will be any problems later on.
Comment 25 Michael Young 2003-04-20 17:06:20 EDT
Most likely some other bug caused your database to go missing, quite possibly
related to the reason why you wanted to rebuild your database in the first
place, because this bug (or at least the originally reported one) really is
harmless. If you want to report your problem open a fresh bug report, because
this report is closed and will stay closed.
Comment 26 Jon Hart 2003-04-21 15:23:08 EDT
As a variation on the 'nosysinfo' boot option, you can also play with the
LD_ASSUME_KERNEL environmental variable.

For example, on my system, the db rebuild completes silently using the following
command:

[root@diana root]# LD_ASSUME_KERNEL=2.2.5 rpm --rebuilddb
Comment 27 NILMONI DEB 2003-05-02 16:09:28 EDT
I have a clean redhat 9 install with all package updates applied (till toady). 
kernel-2.4.20-9 
glibc-2.3.2-27.9 
 
I am trying to rebuild my rpm db using: 
 
	rpm --rebuilddb 
 
It runs for sometime and then gives this error message: 
 
	error: db4 error(16) from dbenv->remove: Device or resource busy 
 
I ran "rpm --rebuilddb -vv" and it showed the error at the very end but 
completed just fine. Any idea when it will be fixed ? 
 
Comment 28 Barry K. Nathan 2003-05-02 20:19:29 EDT
Nilmoni (and anyone else asking "When?"), look at comment #6 for bug 88273:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=88273#c6
Comment 29 Jerry Cornelius 2003-05-10 13:53:25 EDT
Regarding this comment:

------- Additional Comment #13 From Barry K. Nathan on 2003-04-09 04:09 -------

Marcus, that does not fix it for me either. Nor do the new test-4.2 RPM packages
at ftp.rpm.org (rpm-4.2-1).

What *does* seem to fix the problem for me is booting with "nosysinfo"...

And regarding other related warnings of bug importance:

As reported, the nosysinfo kludge works, but it has ramifications beyond the
supression of a spurious error message.  Java developers should be wary using
this boot-time option as it relates to threading.  Read this thread and pay
special attention to message #12:

http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&threadm=b2b3c5e1.0303281331.66f0b30b%40posting.google.com&rnum=2&prev=/groups%3Fhl%3Den%26lr%3D%26ie%3DUTF-8%26oe%3DUTF-8%26q%3Dnosysinfo%2Bboot%2Btime%2Boption%26sa%3DN%26tab%3Dwg
Comment 30 Marcus Alves Grando 2003-05-10 16:01:39 EDT
For me works, but i use kernel 2.5.x
Comment 31 Chris Ricksen 2003-07-26 15:05:54 EDT
After installing realplayer 8 which does not work I attempted to install it a
second time rpm responded with "already installed".  When I try to remove it 
rpm -e rp8... it says "not installed".  When I then ran rpm --reuilddb it comes
back with db4 error(16) device busy.  I am running rh 9 4.20-18-9. I ahve tired
all of the sugested fixes minus nosysinfo and it still fails.  How can I remove
the realplayer which says it is already installed and not installed?
Comment 32 Michael Young 2003-07-26 15:31:03 EDT
Your problem is probably nothing to do with your rpm database, but is likely to
be a common error when using rpm. When you add packages you run rpm -U
filename.rpm but to remove packages you run rpm -e packagename, eg. rpm -e rpm
(though don't try that example).
Comment 33 Need Real Name 2003-09-19 16:38:16 EDT
rpm-4.2-0.69 
kernel-smp-2.4.20-8 
glibc-2.3.2-27.9 
 
Same old story: Message on closing. 
Comment 34 ketil vestby 2003-10-15 13:19:20 EDT
I have just spent a day on this bug, googling and reading about it  
"everywhere". This is one of the bugs that cost market shares. I hope there 
will be a way of upgrading RPM to a more bugfree version someday... 
 
Is this similar to believing on Santa? 
Comment 35 Michael Young 2003-10-16 04:23:50 EDT
The simplest fix is just to ignore the error message, since it doesn't affect
functionality, but you can also upgrade to the fedora test releases where the
error message no longer occurs.
Comment 36 Mark Richards 2003-12-24 10:12:08 EST
It doesn't work for me. :)

The start of this problem was that Up2Date seemed frozen (i'm new to
red hat, so don't know if there's a windows equivalent to a task list
to examine).  I finally forced the process to close (hat to restart).

Since this, I see that redhat-printer-config is in the update list
(RHBA-2003:276-06 -- 0.6.47.1, but each attempt tells me "Test install
failed because of package conflicts:
package redhat-config-printer-gui-0.6.47.11-1 is already installed"

I investigated rpm --rebuilddb as a possible solution, and this led me
here.  

If this is the wrong place to post this, sorry.  Please lead me to a
more appropriate bug discussion.

This isn't a serious bug (i hope not) but makes me a little worried
that other updates might not be applied properly and also that the
update system can apparently be mangled by a restart.
Comment 37 Mimmus 2004-05-26 11:04:37 EDT
Sorry but this problem is unresolved.
Why this bug is closed?
Comment 38 Barry K. Nathan 2004-05-26 15:25:56 EDT
Mimmus, what release of Red Hat or Fedora Core are you using? If you
have applied all updates to Red Hat Enterprise Linux 3, or you are
running Fedora Core 1 or Fedora Core 2, then this bug should in fact
be fixed. Red Hat 9 has now reached "end-of-life", and it would be
best to upgrade.

(The Fedora Legacy project <http://www.fedoralegacy.org/> will
continue to produce security updates for Red Hat 9, but I don't think
Fedora Legacy is likely to backport the fix for this bug; the db4
error message is harmless, and Fedora Legacy has bigger problems to be
concerned with.)
Comment 39 Mimmus 2004-05-27 12:25:57 EDT
Well, I understand.
Even if we run RH AS 3 in many production servers, in this case I'm
using  RH 9 because: 
- it is free
- I think that it is lighter for small (outdated) servers
- I believe (I hope?) in Fedora Legacy project

If message is harmless, as you say, I can continue my work...

Thanks for your response

Note You need to log in before you can comment on or make changes to this bug.