Bug 882991 - Error in dmraid %postun: /sbin/ldconfig: relative path `1' used to build cache
Error in dmraid %postun: /sbin/ldconfig: relative path `1' used to build cache
Status: CLOSED DUPLICATE of bug 877840
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-03 10:16 EST by Richard W.M. Jones
Modified: 2012-12-03 10:56 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 10:56:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-12-03 10:16:47 EST
Description of problem:

This doesn't look good ...

  Cleanup    : dmraid-1.0.0.rc16-17.fc18.x86_64                                             323/576 
/sbin/ldconfig: relative path `1' used to build cache
warning: %postun(dmraid-1.0.0.rc16-17.fc18.x86_64) scriptlet failed, exit status 1
Non-fatal POSTUN scriptlet failure in rpm package dmraid-1.0.0.rc16-17.fc18.x86_64

Version-Release number of selected component (if applicable):

See above.
Comment 1 Richard W.M. Jones 2012-12-03 10:17:49 EST
The scriptlet looks suspicious, although not actually wrong:

$ rpm -q --scripts dmraid
postinstall program: /sbin/ldconfig
postuninstall scriptlet (using /bin/sh):
/sbin/ldconfig

# 1. Main package


[The # 1. etc seems to be part of the %postun script]
Comment 2 Peter Rajnoha 2012-12-03 10:56:08 EST
It should be fixed already, but the change will apply only with a future update of dmraid as %postun scriptlet is called for the old package. So once updated to dmraid-1.0.0.rc16-18.fc18, the error should not appear anymore.

*** This bug has been marked as a duplicate of bug 877840 ***

Note You need to log in before you can comment on or make changes to this bug.