This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 883206 - running xrestop crashes the server
running xrestop crashes the server
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dave Airlie
Desktop QE
: Regression
: 883212 (view as bug list)
Depends On:
Blocks: 886216
  Show dependency treegraph
 
Reported: 2012-12-03 22:19 EST by Dave Airlie
Modified: 2013-02-21 03:04 EST (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-server-1.13.0-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:04:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Airlie 2012-12-03 22:19:15 EST
Launch xrestop against a server running on intel/ati or nouveau drivers, it will crash the server.

The fix is a two line patch upstream to make sure RRProviderInit is called at the correct time.
Comment 2 Tomas Pelka 2012-12-04 04:02:43 EST
*** Bug 883212 has been marked as a duplicate of this bug. ***
Comment 3 RHEL Product and Program Management 2012-12-04 04:11:14 EST
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 5 RHEL Product and Program Management 2012-12-04 04:51:27 EST
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 6 Dave Airlie 2012-12-04 18:36:50 EST
MODIFIED

xorg-x11-server-1.13.0-8 is built in brew
Comment 10 errata-xmlrpc 2013-02-21 03:04:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0299.html

Note You need to log in before you can comment on or make changes to this bug.