Bug 883212 - running xrestop crashes the server
running xrestop crashes the server
Status: CLOSED DUPLICATE of bug 883206
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: Regression
: 883207 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2012-12-03 22:38 EST by Dave Airlie
Modified: 2012-12-04 04:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-12-04 04:02:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave Airlie 2012-12-03 22:38:20 EST
Launch xrestop against a server running on intel/ati or nouveau drivers, it will crash the server.

The fix is a two line patch upstream to make sure RRProviderInit is called at the correct time.
Comment 2 RHEL Product and Program Management 2012-12-03 23:01:19 EST
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 3 Dave Airlie 2012-12-03 23:46:15 EST
*** Bug 883207 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Pelka 2012-12-04 04:02:43 EST

*** This bug has been marked as a duplicate of bug 883206 ***

Note You need to log in before you can comment on or make changes to this bug.