Bug 883372 - SELinux is preventing /usr/sbin/condor_procd from using the 'kill' capabilities.
Summary: SELinux is preventing /usr/sbin/condor_procd from using the 'kill' capabilities.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d6aa6f4d68f35be8e0f6a9befa4...
: 883371 883373 883374 883375 883376 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-04 12:33 UTC by Matthew Farrellee
Modified: 2013-01-07 04:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-07 04:03:12 UTC
Type: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-12-04 12:33 UTC, Matthew Farrellee
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-12-04 12:33 UTC, Matthew Farrellee
no flags Details

Description Matthew Farrellee 2012-12-04 12:33:16 UTC
Additional info:
libreport version: 2.0.18
kernel:         3.6.7-4.fc17.x86_64

description:
:SELinux is preventing /usr/sbin/condor_procd from using the 'kill' capabilities.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that condor_procd should have the kill capability by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep condor_procd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:condor_procd_t:s0
:Target Context                system_u:system_r:condor_procd_t:s0
:Target Objects                 [ capability ]
:Source                        condor_procd
:Source Path                   /usr/sbin/condor_procd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           condor-procd-7.9.1-0.1.fc17.2.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-161.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.7-4.fc17.x86_64 #1 SMP Tue Nov
:                              20 19:40:01 UTC 2012 x86_64 x86_64
:Alert Count                   7
:First Seen                    2012-12-01 09:42:45 EST
:Last Seen                     2012-12-04 06:28:26 EST
:Local ID                      610fbfba-62fc-443c-9d8e-42149e03a9f8
:
:Raw Audit Messages
:type=AVC msg=audit(1354620506.929:2845): avc:  denied  { kill } for  pid=16941 comm="condor_procd" capability=5  scontext=system_u:system_r:condor_procd_t:s0 tcontext=system_u:system_r:condor_procd_t:s0 tclass=capability
:
:
:type=AVC msg=audit(1354620506.929:2845): avc:  denied  { sigkill } for  pid=16941 comm="condor_procd" scontext=system_u:system_r:condor_procd_t:s0 tcontext=system_u:system_r:condor_startd_t:s0 tclass=process
:
:
:type=SYSCALL msg=audit(1354620506.929:2845): arch=x86_64 syscall=kill success=yes exit=0 a0=58a0 a1=9 a2=9 a3=18 items=0 ppid=2867 pid=16941 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=condor_procd exe=/usr/sbin/condor_procd subj=system_u:system_r:condor_procd_t:s0 key=(null)
:
:Hash: condor_procd,condor_procd_t,condor_procd_t,capability,kill
:
:audit2allow
:
:#============= condor_procd_t ==============
:allow condor_procd_t condor_startd_t:process sigkill;
:allow condor_procd_t self:capability kill;
:
:audit2allow -R
:
:#============= condor_procd_t ==============
:allow condor_procd_t condor_startd_t:process sigkill;
:allow condor_procd_t self:capability kill;
:

Comment 1 Matthew Farrellee 2012-12-04 12:33:19 UTC
Created attachment 657472 [details]
File: type

Comment 2 Matthew Farrellee 2012-12-04 12:33:21 UTC
Created attachment 657473 [details]
File: hashmarkername

Comment 3 Miroslav Grepl 2012-12-04 13:40:40 UTC
Added.

commit 09c88f4ee3e45b6aac89bb7f2f95d236f29e8812
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Tue Dec 4 14:38:37 2012 +0100

    Allow condor_master to create /tmp files/dirs
    Allow condor_mater to send sigkill to other condor domains
    Allow condor_procd sigkill capability

Comment 4 Miroslav Grepl 2012-12-04 13:40:50 UTC
*** Bug 883371 has been marked as a duplicate of this bug. ***

Comment 5 Miroslav Grepl 2012-12-04 13:40:58 UTC
*** Bug 883373 has been marked as a duplicate of this bug. ***

Comment 6 Miroslav Grepl 2012-12-04 13:41:04 UTC
*** Bug 883374 has been marked as a duplicate of this bug. ***

Comment 7 Miroslav Grepl 2012-12-04 13:41:35 UTC
*** Bug 883376 has been marked as a duplicate of this bug. ***

Comment 8 Miroslav Grepl 2012-12-04 13:42:07 UTC
*** Bug 883375 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2012-12-17 18:43:37 UTC
selinux-policy-3.10.0-165.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-165.fc17

Comment 10 Fedora Update System 2012-12-18 02:39:40 UTC
Package selinux-policy-3.10.0-165.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-165.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20544/selinux-policy-3.10.0-165.fc17
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2013-01-05 06:44:22 UTC
Package selinux-policy-3.10.0-166.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-166.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20544/selinux-policy-3.10.0-166.fc17
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2013-01-07 04:03:14 UTC
selinux-policy-3.10.0-166.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.