Bug 883376 - SELinux is preventing /usr/sbin/condor_master from using the 'sigkill' accesses on a process.
Summary: SELinux is preventing /usr/sbin/condor_master from using the 'sigkill' access...
Keywords:
Status: CLOSED DUPLICATE of bug 883372
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4c445cd831461d5083bd2b3cf5e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-04 12:35 UTC by Matthew Farrellee
Modified: 2012-12-04 13:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-04 13:41:18 UTC
Type: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-12-04 12:35 UTC, Matthew Farrellee
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-12-04 12:35 UTC, Matthew Farrellee
no flags Details

Description Matthew Farrellee 2012-12-04 12:35:04 UTC
Additional info:
libreport version: 2.0.18
kernel:         3.6.7-4.fc17.x86_64

description:
:SELinux is preventing /usr/sbin/condor_master from using the 'sigkill' accesses on a process.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that condor_master should be allowed sigkill access on processes labeled condor_startd_t by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep condor_master /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:condor_master_t:s0
:Target Context                system_u:system_r:condor_startd_t:s0
:Target Objects                 [ process ]
:Source                        condor_master
:Source Path                   /usr/sbin/condor_master
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           condor-7.9.1-0.1.fc17.2.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-161.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.7-4.fc17.x86_64 #1 SMP Tue Nov
:                              20 19:40:01 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-12-03 17:44:55 EST
:Last Seen                     2012-12-03 17:44:55 EST
:Local ID                      bf20b743-11d9-4a71-ad8c-45e6e7060fbe
:
:Raw Audit Messages
:type=AVC msg=audit(1354574695.853:926): avc:  denied  { sigkill } for  pid=2867 comm="condor_master" scontext=system_u:system_r:condor_master_t:s0 tcontext=system_u:system_r:condor_startd_t:s0 tclass=process
:
:
:type=SYSCALL msg=audit(1354574695.853:926): arch=x86_64 syscall=kill success=yes exit=0 a0=4239 a1=9 a2=0 a3=16 items=0 ppid=1 pid=2867 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=condor_master exe=/usr/sbin/condor_master subj=system_u:system_r:condor_master_t:s0 key=(null)
:
:Hash: condor_master,condor_master_t,condor_startd_t,process,sigkill
:
:audit2allow
:
:#============= condor_master_t ==============
:allow condor_master_t condor_startd_t:process sigkill;
:
:audit2allow -R
:
:#============= condor_master_t ==============
:allow condor_master_t condor_startd_t:process sigkill;
:

Comment 1 Matthew Farrellee 2012-12-04 12:35:07 UTC
Created attachment 657480 [details]
File: type

Comment 2 Matthew Farrellee 2012-12-04 12:35:09 UTC
Created attachment 657481 [details]
File: hashmarkername

Comment 3 Miroslav Grepl 2012-12-04 13:41:18 UTC

*** This bug has been marked as a duplicate of bug 883372 ***


Note You need to log in before you can comment on or make changes to this bug.