This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 88342 - XFree86 installation and run fail on Dell 8250
XFree86 installation and run fail on Dell 8250
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On: 84834
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-09 00:41 EDT by Hardy Mayer
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version: XFree86-4.3.0-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-28 02:08:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The Log file before screen goes blank! (31.59 KB, text/plain)
2003-04-09 00:44 EDT, Hardy Mayer
no flags Details
XF86Config (3.16 KB, text/plain)
2003-04-09 00:45 EDT, Hardy Mayer
no flags Details
Output of lspci -vv (9.00 KB, text/plain)
2003-04-09 03:00 EDT, Hardy Mayer
no flags Details
output of lspci -vvn (7.87 KB, text/plain)
2003-04-09 03:02 EDT, Hardy Mayer
no flags Details

  None (edit)
Description Hardy Mayer 2003-04-09 00:41:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b)
Gecko/20030407
(I am sending this from my Mac since X does not work under 9! ;-( )
Description of problem:
1. X fails to start on the Dell 8250 with Radeon 9700 card during installation,
-- screen goes blank. 
I updated in text-mode and everything works except X!
As reported previously (Bug 85420)  X worked fine in RH 8.0.93. 

I am attaching the log file and my XF86Config file created by the installation. 

Version-Release number of selected component (if applicable):
RedHat 9-3, XFree86-4.3.0-2, kernel 2.4.20-8

How reproducible:
Always

Steps to Reproduce:
1. Run "linux nousb" (in order to overcome the keynoard problem on the Dell). 
2. It detects the Radeon 9700 card, the FP 1702 Monitor and the PS/2 Mouse
3.Screen goes blank, moitor tunrs off!
    

Expected Results:  A working X11 update/isstall screen!

Additional info:

Should I try to reinstall 8.0.93 -- or can you suggest a fix?
Comment 1 Hardy Mayer 2003-04-09 00:44:30 EDT
Created attachment 91027 [details]
The Log file  before screen goes blank!
Comment 2 Hardy Mayer 2003-04-09 00:45:22 EDT
Created attachment 91028 [details]
XF86Config
Comment 3 Hardy Mayer 2003-04-09 03:00:10 EDT
Created attachment 91032 [details]
Output of  lspci -vv

The output of lspci -vv

The ATI card is listed twice!
Comment 4 Hardy Mayer 2003-04-09 03:00:52 EDT
This is seems to be a PCI-problem with the newer Itel motherboard.
lspci lists two entries PCI:1.0.1 and PCI:1.0.0 for the radeon card. 
If if enter either of them by hand in XF86Config (s BUSId "PCI:1.0.1"
the other one appears in the warning on startup. 
I am attaching the output of lspci -vv and lspci -vvn 
Comment 5 Hardy Mayer 2003-04-09 03:02:02 EDT
Created attachment 91033 [details]
output of lspci -vvn
Comment 6 Hardy Mayer 2003-04-09 03:12:38 EDT
One more thought: 
Since the card has bot VGA and DVI outputs, could it be that X is running on the
analog output while the monitor is connected to the digital one? 
Judging by the lspci output the digital PCI device 1:0.1 is "unknown"

On the other hand the system worked fine with redhat 8.0.93 and kernel 2.4.20-2.28
(or what ever), with XFre86-4.2.99 ... What has changed after 8.0.93? 
Comment 7 Hardy Mayer 2003-04-09 03:41:02 EDT
I just noticed bug 84834 which exhibits similar behavior on dual-head cards. 
I suppose that redhat-configure-xfree86 needs to be fixed to take into account 
both entries on the PCI-bus and produce the correct entries in XF86Config. 
In the meantime could someone perhaps suggest how to do this by hand? 
Comment 8 Mike A. Harris 2003-04-09 04:48:28 EDT
Please attach your X server log and config file.  I've no idea what the
problem could be, but we can try to find out.

Do not reinstall the phoebe beta as we do not support beta products once
the final release of our OS is released, so any problems you encounter
with the beta releases will be unsupported unless you reinstall the final
release and reproduce them.
Comment 9 Mike A. Harris 2003-04-09 05:00:08 EDT
Um, I must be incredibly blind.  Ignore my first paragraph in my  last
comment.  No idea how I missed your file attachments. Must be one of those
days.  ;o)

> The ATI card is listed twice!

No, it is not.  The card has 2 devices on it, so it shows up with 2 PCI IDs,
which is normal and expected correct behaviour for Radeon 9700.

I just looked at your attached log file, config file, and lspci info.
The config file appears to be configured correctly, and your log file shows
the X server starting up properly also with no failures.

It is not clear yet what the problem is.

(II) RADEON(0): Manufacturer: DEL  Model: 3006  Serial#: 1144146513
(II) RADEON(0): Year: 2003  Week: 4
(II) RADEON(0): EDID Version: 1.3
(II) RADEON(0): Digital Display Input
(II) RADEON(0): Max H-Image Size [cm]: horiz.: 34  vert.: 27
(II) RADEON(0): Gamma: 2.40
(II) RADEON(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
(II) RADEON(0): First detailed timing is preferred mode
(II) RADEON(0): redX: 0.634 redY: 0.354   greenX: 0.304 greenY: 0.581
(II) RADEON(0): blueX: 0.143 blueY: 0.102   whiteX: 0.318 whiteY: 0.339
(II) RADEON(0): Supported VESA Video Modes:
(II) RADEON(0): 720x400@70Hz
(II) RADEON(0): 640x480@60Hz
(II) RADEON(0): 640x480@75Hz
(II) RADEON(0): 800x600@60Hz
(II) RADEON(0): 800x600@75Hz
(II) RADEON(0): 1024x768@60Hz
(II) RADEON(0): 1024x768@75Hz
(II) RADEON(0): 1280x1024@75Hz
(II) RADEON(0): Manufacturer's mask: 0
(II) RADEON(0): Supported Future Video Modes:
(II) RADEON(0): #0: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
(II) RADEON(0): #1: hsize: 1152  vsize 864  refresh: 75  vid: 20337
(II) RADEON(0): Supported additional Video Mode:
(II) RADEON(0): clock: 108.0 MHz   Image Size:  338 x 270 mm
(II) RADEON(0): h_active: 1280  h_sync: 1328  h_sync_end 1440 h_blank_end 1688
h_border: 0
(II) RADEON(0): v_active: 1024  v_sync: 1025  v_sync_end 1028 v_blanking: 1066
v_border: 0
(II) RADEON(0): Serial No: 8G15231KD2JQ
(II) RADEON(0): Monitor name: DELL 1702FP
(II) RADEON(0): Ranges: V min: 56  V max: 76 Hz, H min: 30  H max: 80 kHz,
PixClock max 140 MHz
(II) RADEON(0): End of DDC Monitor info



Comment 10 Mike A. Harris 2003-04-09 05:33:13 EDT
Since it isn't clear exactly what the problem is yet, and it isn't clear
what is causing the problem, it is quite difficult to suggest a workaround
or a fix to the problem right now other than to look at the "radeon" man
page, and experiment with options.

Your best bet right now, is to ask for help on xfree86@xfree86.org mailing
list, and see if someone else has encountered the problem you are having
already, and wether they've found a fix or a workaround already or not, and
then add that info here if you can.

Hope this helps.
Comment 11 Hardy Mayer 2003-04-09 11:43:57 EDT
Thnks Mike!
If you look further down in the log file you'll find 
(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) found

and ususally ths is foolwed on vc1 by an
(EE)  ... aborting message. 
Sometimes it goes further and lists a few 
 gnome error messages, but the monitor stays black. 

Would it make sense to add two videocard entries  with PCIBus 1.0.0 and 1.0.1 
and link the display to 1.0.1 which seems to be the dvi part of the radeon? 

And is there an explanation why things worked fine with 8.0.93 and then stopped
working? 
Comment 12 Mike A. Harris 2003-04-09 12:35:48 EDT
As I said quite clearly above, I am not confirming nor denying that there
is a bug here.  I simply do not know.  Since I can neither confirm nor
deny wether or not there is a bug, lets hypothetically assume there is one,
or that there is a change in behaviour - again, which I am not confirming
nor denying.  If in fact there is a change, I have absolutely no idea what
it is, and thus I can not explain why it would have worked before and does
not now.  It could be absolutely anything.

Please follow the suggestions I gave above.  I will be unable to look into
this problem further for quite some time, so if you're looking for a quick
workaround or explanation of what is wrong, I will be unable to provide you
with that.  Please use the xfree86@xfree86.org mailing list for speedy
answers.  Bugzilla is not a technical support forum, but rather it is a bug
tracker.  The problem will be tracked until it either a solution is found, or
it is deemed to not be a bug, or some other resolution, however I have
other priorities right now, and won't be able to investigate this matter
further any time soon, in particular without having a flat panel display.

xfree86 mailing list is your best bet.  Or feel free to use phoebe beta, or
whatever else meets your needs in the mean time.  Just realize that bugzilla
is not a tech support forum.
Comment 13 Hardy Mayer 2003-04-09 14:05:22 EDT
Thanks -- I'll try the xfree86 bug system.
In the meantime I have reinstalled  XFree86-4.2.99.3-20030115.0 from the 8.0.93 
phoebe beta and it works like a charm -- in case other people have problems with
the Dell/Radeon combination.
Comment 14 Hardy Mayer 2003-04-10 10:56:43 EDT
Thnks Mike!
If you look further down in the log file you'll find 
(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) found

and ususally ths is foolwed on vc1 by an
(EE)  ... aborting message. 
Sometimes it goes further and lists a few 
 gnome error messages, but the monitor stays black. 

Would it make sense to add two videocard entries  with PCIBus 1.0.0 and 1.0.1 
and link the display to 1.0.1 which seems to be the dvi part of the radeon? 

And is there an explanation why things worked fine with 8.0.93 and then stopped
working? 
Comment 15 Mike A. Harris 2003-04-11 07:08:30 EDT
Deferring for next development cycle.
Comment 16 Hardy Mayer 2003-04-28 02:07:29 EDT
XFree86-4.3.0-5 seems to fix this bug.  
I installed it and XFree works fine now.  Thanks Mike for kowingly or
accidentally fixing the problem with the Radeon 9700 on the Dell 8250 (and
hopefully the related NVidia problems)!

Note You need to log in before you can comment on or make changes to this bug.