Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 883855 - Use guest agent to report logged in users
Summary: Use guest agent to report logged in users
Keywords:
Status: CLOSED DUPLICATE of bug 879586
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Frantisek Kobzik
QA Contact: Jiri Belka
URL:
Whiteboard: virt
: 859097 (view as bug list)
Depends On:
Blocks: 880589
TreeView+ depends on / blocked
 
Reported: 2012-12-05 12:41 UTC by Andrew Cathrow
Modified: 2014-09-07 22:55 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-11 08:56:27 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Andrew Cathrow 2012-12-05 12:41:34 UTC
Today we display in the UI and the API the logged in user that is taken from the Spice ticket.

We want to move (back to) use the user reported by the guest agent

On both Windows and Linux we may find that multiple users are reported (eg. multiple RDP sessions etc).

In this case we want to report the first user in the list, without any heuristics.

We should store all the users reported by the agent but only use the first one for any reporting/API etc.

Comment 1 Frantisek Kobzik 2012-12-05 13:20:36 UTC
*** Bug 879586 has been marked as a duplicate of this bug. ***

Comment 11 Jiri Belka 2013-03-25 14:08:57 UTC
FYI see side-effects https://bugzilla.redhat.com/show_bug.cgi?id=879586#c11

Comment 13 Andrew Cathrow 2013-03-30 20:28:15 UTC
resetting pm ack.

Comment 15 Itamar Heim 2013-04-28 06:58:40 UTC
*** Bug 859097 has been marked as a duplicate of this bug. ***

Comment 16 Andrew Cathrow 2013-09-11 08:56:27 UTC

*** This bug has been marked as a duplicate of bug 879586 ***


Note You need to log in before you can comment on or make changes to this bug.