Bug 88402 - (USB STORAGE)usb-storage fails to work on archos recorder 20GB (USB2)
(USB STORAGE)usb-storage fails to work on archos recorder 20GB (USB2)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
high Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
http://rohirrim.org/bug/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-09 16:28 EDT by rohirrim
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-29 15:22:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
devices from rohirrim (5.81 KB, text/plain)
2003-04-14 15:22 EDT, Pete Zaitcev
no flags Details
dmesg from rohirrim (12.32 KB, text/plain)
2003-04-14 15:25 EDT, Pete Zaitcev
no flags Details
max_sectors (517 bytes, patch)
2003-11-19 12:52 EST, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description rohirrim 2003-04-09 16:28:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I have an archos recorder 20GB mp3 player (USB2 device) connected to a NEC USB2
controller, supported by the ehci module. The device works as a usb mass storage
device. This device worked (and still does) correctly on redhat 8
(kernel-2.4.18-x). Under redhat 9, using kernel-2.4.20-8 or kernel-2.4.20-9,
"timeouts" happen when I transfer data to and from the device (which happens
VERY slowly for some reason, even though it's a USB2 device) and the process
that transfers the data hangs. I can't control-C it, and I cannot even shutdown
the machine. The bug is always reproducable. Syslog doesn't show anything
suspicious. I've tried recompiling the supplied kernel, but to no avail. On the
other hand, a plain 2.4.20 kernel does work perfectly on the same machine. On
the suplpied url, you'll find a copy of dmesg and /proc/usb/devices running on
2.4.20-8. I thought that 2.4.20-9 fixes usb-storage problems
(https://rhn.redhat.com/errata/RHSA-2003-135.html ) but it doesn't for me. This
problem might be related to bugs 85822 & 85821. Please contact me if you want
more information.

Version-Release number of selected component (if applicable):
kernel-2.4.20-8 & kernel-2.4.20-9

How reproducible:
Always

Steps to Reproduce:
1. Install redhat9 (kernel-2.4.20-8 or -9)
2. Mount the usb-storage device (archos recorder USB2 20 GB)
3. copy data to/from the device
    

Actual Results:  Process "hangs" some seemingly random (but short) time. Cannot
interrupt it. Machine cannot shutdown.

Expected Results:  Files copied, process terminated

Additional info: http://rohirrim.org/bug/
Comment 1 Glenn Callow 2003-04-13 05:32:58 EDT
Similar problem with USB-2.0 PNY 6 in 1 Flash Adapter (both with SD and Compact
Flash).  Device mounts OK under both 2.4.20-8 and 9 but locks completely if any
data is transferred, or if mkfs and fdisk is used.  Device will not come back up
without a reboot.

Problem is down to the ehci-hcd module - simply removing the module (i.e. just
using the usb-uhci module) results in correct operation.  Temporary fix is to
remove the alias usb-controller ehci-hcd line in /etc/modules.conf.

System is based around a Via 8235 chipset with a Via USB 2.0 controller on the
motherboard.
Comment 2 Pete Zaitcev 2003-04-14 15:22:08 EDT
Created attachment 91130 [details]
devices from rohirrim
Comment 3 Pete Zaitcev 2003-04-14 15:25:26 EDT
Created attachment 91131 [details]
dmesg from rohirrim
Comment 4 Pete Zaitcev 2003-04-14 15:28:22 EDT
Was that dmesg taken before the hang or after the hang?

The error on the sector zero looks like improper use of US_FL_START_STOP,
but it wouldn't cause the symptoms.
Comment 5 rohirrim 2003-04-14 19:08:08 EDT
The dmesg was taken _after_ the problem. /dev/sda is a no-name usb compact flash
reader, which for some reason is accessed periodically or when I try to mount
the archos jukebox (which is /dev/sdb). This error was probably generated
because there was no card in the reader. 

As far as I'm aware, the bug does not produce any messages in dmesg.
Comment 6 Pete Zaitcev 2003-06-03 15:31:02 EDT
Would you please to test the 2.4.20-18? I suspect the upstread destroyed
usb-uhci right when we pricked it for -8 & -13.
Comment 7 rohirrim 2003-06-03 19:12:25 EDT
Bug continues with both -8 & -13. Correct behaviour is only observed with 2.4.20
vanilla.
Comment 8 Pete Zaitcev 2003-06-03 19:41:11 EDT
I am asking about 2.4.20-18 (DASH EIGHTEEN). Please test.
Comment 9 rohirrim 2003-06-03 20:20:10 EDT
Problem continues in -18 (which is what i meant before -sorry for the mistake)
Comment 10 rohirrim 2003-06-22 16:10:22 EDT
I just installed kernel 2.4.21 (vanilla), under which the device has the exact
same problem. So, whatever is causing the problem was added to kernel 2.4.21...

To summarise, the device works under:
RH9 (kernel 2.4.20 (vanilla)) ehci, uhci
RH9 (kernel 2.4.21/2.4.20-redhat) uhci only
RH8 (all RH kernels before RH9 came out) ehci, uhci
WinXP ehci, uhci

The device does not work under:
RH9 (kernel 2.4.21 (vanilla), all redhat kernels) ehci

Comment 11 Pete Zaitcev 2003-08-07 22:14:27 EDT
Report noise snapshot:

http://marc.theaimsgroup.com/?l=linux-usb-devel&m=104556288529260&w=2
 -- Same vt8235, looks like hotplug race in ehci-hcd
http://marc.theaimsgroup.com/?l=linux-usb-devel&m=101915871709820&w=2
 -- Longish thread head: problems with error handling in usb-storage,
    looks more like bug 100887
http://marc.theaimsgroup.com/?l=linux-usb-users&m=104827171302907&w=2
 -- Needs recheck if we have that patch
Comment 12 rohirrim 2003-09-01 07:18:52 EDT
Just to mention that the device works correctly using kernel 2.4.22 (vanilla).
Comment 13 Frode Tennebø 2003-11-17 07:34:51 EST
I have experienced similar problems with 2.4.20-20.9.

Trying to copy files to my Maxtor 5000XT usb disk gives more or less 
the same behaviour as described above. Unfortunately, due to the 
severe nature of the hang, /var/log/messages is not updated. I only 
get:

Nov 17 12:26:21 garvin kernel: Unable to handle kernel paging request 
at virtual address 0974c928
Nov 17 12:26:21 garvin kernel:  printing eip:

Then I manually have to power off and on the beast and the log 
continues:

Nov 17 13:35:58 garvin syslogd 1.4.1: restart.
:
:

The console is  however, much more feature rich when it comes to 
printouts.
Comment 14 Pete Zaitcev 2003-11-19 12:18:09 EST
Oops, completely forgot about Frode. His case obviosly has nothing
to do with this particular bug. He needs to get a serial console
or netconsole set up and capture the trace, and open his own bug.
Comment 15 Pete Zaitcev 2003-11-19 12:52:08 EST
Created attachment 96063 [details]
max_sectors
Comment 16 Pete Zaitcev 2003-11-19 12:53:10 EST
This is a shot in the dark, but perhaps attached patch (max_sectors)
might have something to do with this.
Comment 17 Pete Zaitcev 2004-01-17 14:32:08 EST
Well, did anyone have a chance to try the Archos on Fedora
with 2.4.21-1.2140? It does have the sector limit, and it
does have my anti-lockup fixes (for Frode :-)).

Guys, I need your feedback, as precise and complete as possible.
Otherwise nothing will get fixed, ever.
Comment 18 rohirrim 2004-06-26 15:56:15 EDT
Appologies for the very late reply. I'm afraid my archos was stolen in
november and I couldn't have tested the patches.
Comment 19 Pete Zaitcev 2004-07-29 15:21:59 EDT
I'm sorry to hear the bad news from the requestor. I'm closing this bug.

Frode, Glen, the FC1 is not likely to see a non-security update,
so if you wish to stick with 2.4, get latest (-1.2198) and maybe
it works now. I did some good work there, basically porting
storage fixes from RHEL 3.

But it would be better if you moved to FC2 and filed bugs for
any problems there.

Note You need to log in before you can comment on or make changes to this bug.