Bug 884639 - [rhevm-upgrade] Need to add dwh and reports to rollback steps
[rhevm-upgrade] Need to add dwh and reports to rollback steps
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.1.1
Assigned To: Moran Goldboim
Pavel Stehlik
integration
: ZStream
Depends On: 880630
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-06 08:25 EST by Chris Pelland
Modified: 2013-01-15 10:14 EST (History)
10 users (show)

See Also:
Fixed In Version: si25
Doc Type: Bug Fix
Doc Text:
When upgrading from Red Hat Enterprise Virtualization Manager 3.0 to 3.1 if the upgrade process fails then instructions to roll back the changes are displayed to the user. Previously these instructions omitted the steps required to roll back the history database used by the reporting engine. The rhevm-upgrade script has been upgraded and now provides steps for rolling back the history database in the event that the upgrade process fails.
Story Points: ---
Clone Of: 880630
Environment:
Last Closed: 2013-01-15 10:14:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log (236.29 KB, application/octet-stream)
2012-12-17 10:49 EST, David Botzer
no flags Details

  None (edit)
Comment 5 David Botzer 2012-12-17 10:48:11 EST
3.1/si25.1
Missing instructions for engine rollback

Should add rollback message for the engine
Since rhevm could be already in 3.1

If we would like to leave engine in 3.1
and it is working
Then
  we should install rhevm-dwh (3.1)
  and rhevm-reports (3.1)
  And run setup for both
----------------------------------------------------

Updating Database...                                     [ DONE ]

 **Error: Upgrade failed, rolling back**
 **Reason: Jasper done backup!!**


To restore DWH perform the following:
1. Install dwh package:
    yum install rhevm-reports-dwh-3.0.8-2
2. Start ETL service:
    service rhevm-etl start
    service rhevm-notifierd start

To restore reports installation perform the following:
1. Install reports packages:
    yum install rhevm-reports-3.0.8-2
2. Stop the JBoss service:
    service jbossas stop
3. Rename the original DB:
    psql -U postgres -c "ALTER DATABASE rhevmreports RENAME TO rhevmreports_orig;"
4. Run reports setup. Answers to interactive questions do not matter:
    rhevm-reports-setup
5. Drop the newly created DB and restore the original one:
    psql -U postgres -c "DROP DATABASE rhevmreports"
    psql -U postgres -c "ALTER DATABASE rhevmreports_orig RENAME TO rhevmreports;"
6. Restart Jboss service:
    service jbossas start

Restoring Database...                                    [ DONE ]
Skipping yum rollback
Starting ovirt-engine...                                 [ DONE ]
Error: Upgrade failed.
please check log at /var/log/ovirt-engine/ovirt-engine-upgrade_2012_12_17_19_40_44.log
* DB Backup available at  /var/lib/ovirt-engine/backups/ovirt-engine_db_backup_2012_12_17_19_40_45.sql
Comment 6 David Botzer 2012-12-17 10:49:35 EST
Created attachment 664937 [details]
log
Comment 8 David Botzer 2012-12-18 05:23:46 EST
Instructions for rhevm (engine)rollback are right and correct,

All instructions for rollback - engine, reports,dwh should be added to upgrade log

/var/log/ovirt-engine/ovirt-engine-upgrade_.log
Comment 13 errata-xmlrpc 2013-01-15 10:14:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0003.html

Note You need to log in before you can comment on or make changes to this bug.