Bug 880630 - [rhevm-upgrade] Need to add dwh and reports to rollback steps
[rhevm-upgrade] Need to add dwh and reports to rollback steps
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.2.0
Assigned To: Moran Goldboim
David Botzer
integration
: ZStream
: 888226 (view as bug list)
Depends On:
Blocks: 884639
  Show dependency treegraph
 
Reported: 2012-11-27 08:08 EST by Kiril Nesenko
Modified: 2014-07-10 20:09 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 884639 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kiril Nesenko 2012-11-27 08:08:48 EST
Description of problem:
Starting upgrade from 3.0 to 3.1. If we fail there are steps for rollback, but dwh and reports are missing.
Need to add dwh and reports to rollback steps

Version-Release number of selected component (if applicable):
rhevm-3.1.0-31.el6ev.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
No rollback available for dwh and reports

Expected results:
Need to add dwh and reports to rollback steps

Additional info:
Comment 4 Moran Goldboim 2013-01-06 09:13:29 EST
*** Bug 888226 has been marked as a duplicate of this bug. ***
Comment 5 David Botzer 2013-01-28 08:09:50 EST
Fixed, 3.1/si26.1
All messages are correct for product and database
Fixed,

Up-to-date instructions are also available at: https://access.redhat.com/knowledge/articles/269333

To restore DWH perform the following:
1. Install dwh package:
	yum install rhevm-reports-dwh-3.0.8-2
2. Start ETL service:
	service rhevm-etl start
	service rhevm-notifierd start


To restore reports installation perform the following:
1. Install reports packages:
	yum install rhevm-reports-3.0.8-2
2. Stop the JBoss service:
	service jbossas stop
3. Rename the original DB:
	psql -U postgres -c "ALTER DATABASE rhevmreports RENAME TO rhevmreports_orig;"
4. Run reports setup. Answers to interactive questions do not matter:
	rhevm-reports-setup
5. Drop the newly created DB and restore the original one:
	psql -U postgres -c "DROP DATABASE rhevmreports"
	psql -U postgres -c "ALTER DATABASE rhevmreports_orig RENAME TO rhevmreports;"
6. Restart Jboss service:
	service jbossas start

Error: Upgrade failed.
please check log
Comment 6 Itamar Heim 2013-06-11 05:45:23 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 05:45:26 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 05:56:00 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.