Bug 884660 - Anaconda fails to load on machines with multiple NICs
Anaconda fails to load on machines with multiple NICs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 887002 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-12-06 09:03 EST by Petr Schindler
Modified: 2012-12-14 16:26 EST (History)
11 users (show)

See Also:
Fixed In Version: anaconda-18.37-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-14 16:26:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (2.75 KB, text/x-log)
2012-12-06 09:03 EST, Petr Schindler
no flags Details
traceback (130.96 KB, text/plain)
2012-12-06 09:04 EST, Petr Schindler
no flags Details
Output from 'journalctl -a' (110.94 KB, application/octet-stream)
2012-12-06 09:04 EST, Petr Schindler
no flags Details
program.log (42.54 KB, text/x-log)
2012-12-06 09:05 EST, Petr Schindler
no flags Details
storage.log (102.59 KB, text/x-log)
2012-12-06 09:05 EST, Petr Schindler
no flags Details
X.log (34.71 KB, text/x-log)
2012-12-06 09:06 EST, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2012-12-06 09:03:19 EST
Description of problem:
I tried to boot netinst.iso written on flash disk by dd, but anaconda failed to load and crashed. The last thing I can see is black screen and cursor (normaly the 'bussy cicrcle cursor' follows). 

The bad think is, that when I click on 'Report Bug' the system is restarted.

But I can get to console, so here is a traceback:
anaconda 18.36 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 467, in createMissingDefaultIfcfgs
    setting = con.GetSettings()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 1028, in networkInitialize
    createMissingDefaultIfcfgs()
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "GetSettings" with signature "" on interface "(null)" doesn't exist

Version-Release number of selected component (if applicable):
anaconda-18.36-x86_64
smoke4

How reproducible:
It happens only on one pc I've tested it on. But on this pc it happens about 90% of time (I see it work only once and failed about 9 times).

Steps to Reproduce:
1. Put smoke4.iso on flash disk with dd
2. Boot and wait
3.
  
Actual results:
Anaconda fails to load

Expected results:
Anaconda starts

Additional info:
Comment 1 Petr Schindler 2012-12-06 09:03:50 EST
Created attachment 658756 [details]
anaconda.log
Comment 2 Petr Schindler 2012-12-06 09:04:13 EST
Created attachment 658757 [details]
traceback
Comment 3 Petr Schindler 2012-12-06 09:04:44 EST
Created attachment 658758 [details]
Output from 'journalctl -a'
Comment 4 Petr Schindler 2012-12-06 09:05:10 EST
Created attachment 658759 [details]
program.log
Comment 5 Petr Schindler 2012-12-06 09:05:49 EST
Created attachment 658760 [details]
storage.log
Comment 6 Petr Schindler 2012-12-06 09:06:26 EST
Created attachment 658761 [details]
X.log
Comment 7 Petr Schindler 2012-12-06 09:10:42 EST
I propose this as blocker bug as it violates the criterion: "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods"
Comment 8 Radek Vykydal 2012-12-06 09:20:16 EST
+1 blocker
This most probably a dupe of 883383, I'll keep this open to track the issue in Fedora. I'd create updates image for version 36, but fetching it over network would most probably spoil the reproducer.
Comment 9 Radek Vykydal 2012-12-06 10:17:27 EST
The issue occurs when NM runs default auto connection for more than one device, for example in these cases:
- 2 NICs, DVD install
- at least 3 NICs, ksdevice and BOOTIF is used as boot option
Comment 10 Stuart Blackburn 2012-12-06 16:47:57 EST
I got this as well using anaconda 18.35 installing via PXE and with a virtual DVD onto a blade and rack-mounted servers with multiple interfaces. We are creating our own spin of FC18, and did not have the problem last week when our iso contained anaconda 18.29.
Comment 11 Adam Williamson 2012-12-10 14:51:36 EST
Discussed at 2012-12-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-10/f18final-blocker-review-3.2012-12-10-17.13.log.txt . Accepted as a blocker per criterion "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods" in the case of multiple connected NICs.
Comment 12 Petr Schindler 2012-12-11 10:12:46 EST
I can run installation with 18.37 on machine with two NICs
Comment 13 Stuart Blackburn 2012-12-11 10:42:20 EST
With anaconda 18.37-1 I was able to install successfully on a 4 NIC server (HP DL360 via ilo) using a virtual DVD. However, I was unable to install through PXE. I now get the following traceback:

Starting installer, one moment...
anaconda 18.37 started
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args , **self,__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 1028, in networkInitialize
    createMissingDefaultIfcfgs()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 469, in createMissingDefaultIfcfgs

    setting['802-3-ethernet']['mac-address'])
  KeyError: 'mac-address'
Comment 14 Stuart Blackburn 2012-12-11 11:07:10 EST
With the failing installation via PXE, I get another traceback later in the installation process that I believe is related to this issue. I am not sure if it should be included in this bug or another. I believe the initial failure to create the ifcfg files causes this subsequent failure.

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 72, in doConfiguration
    ksdata.network.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 759, in execute
    network.write_network_config(storage, ksdata, instClass, ROOT_PATH)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 912, in write_network_config
    write_sysconfig_network(rootpath, ksdata, overwrite=flags.livecdInstall)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 823, in write_sysconfig_network
    dev.loadIfcfgFile()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 305, in loadIfcfgFile
    IfcfgFile.read(self)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/simpleconfig.py", line 187, in read
    SimpleConfigFile.read(self, self.path)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/simpleconfig.py", line 77, in read
    with open(filename) as f:
IOError: [Errno 2] No such file or directory: '/etc/sysconfig/network-scripts/ifcfg-p3p2'
Comment 15 Adam Williamson 2012-12-12 00:48:10 EST
stuart: as this seems to be a different bug, can you please file it separately? Thanks.
Comment 16 Radek Vykydal 2012-12-12 04:05:25 EST
(In reply to comment #15)
> stuart: as this seems to be a different bug, can you please file it
> separately? Thanks.

Also please attach these log files (preferably to the new bug report):

/tmp/anaconda.log
/tmp/syslog
/tmp/ifcfg.log

Thank you.
Comment 17 Stuart Blackburn 2012-12-12 13:51:09 EST
(In reply to comment #16)
> (In reply to comment #15)
> > stuart: as this seems to be a different bug, can you please file it
> > separately? Thanks.
> 
> Also please attach these log files (preferably to the new bug report):
> 
> /tmp/anaconda.log
> /tmp/syslog
> /tmp/ifcfg.log
> 
> Thank you.

Submitted Bug 886647 with the requested files attached. (With the exception of the ifcfg.log which was empty.)
Comment 18 Chris Lumens 2012-12-14 09:58:23 EST
*** Bug 887002 has been marked as a duplicate of this bug. ***
Comment 19 Gene Czarcinski 2012-12-14 10:11:37 EST
Yes, my system also has two NICs besides lots of volume groups (Bug 887002).

I could install using the F18-beta DVD but not the F18-beta-netinstall or any TC1.

I just tried TC2-netinstall and it worked!  Ti make sure, I then rebooted to TC1-netinstall and it failed.
Comment 20 Adam Williamson 2012-12-14 16:26:04 EST
Setting VERIFIED, then. Thanks. Can be closed when 18.37.2 goes stable.

Note You need to log in before you can comment on or make changes to this bug.