Bug 884791 - report-gtk destroys global text cache twice
report-gtk destroys global text cache twice
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
abrt_hash:dd4abfe311bed8ccbc646fa1a59...
:
: 855631 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-06 12:52 EST by Sergio
Modified: 2016-11-30 19:42 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 20:16:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (24.95 KB, text/plain)
2012-12-06 12:52 EST, Sergio
no flags Details
File: cgroup (128 bytes, text/plain)
2012-12-06 12:52 EST, Sergio
no flags Details
File: core_backtrace (3.04 KB, text/plain)
2012-12-06 12:52 EST, Sergio
no flags Details
File: dso_list (7.41 KB, text/plain)
2012-12-06 12:52 EST, Sergio
no flags Details
File: environ (1.13 KB, text/plain)
2012-12-06 12:52 EST, Sergio
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-06 12:52 EST, Sergio
no flags Details
File: maps (21.48 KB, text/plain)
2012-12-06 12:52 EST, Sergio
no flags Details
File: open_fds (400 bytes, text/plain)
2012-12-06 12:52 EST, Sergio
no flags Details
File: proc_pid_status (775 bytes, text/plain)
2012-12-06 12:52 EST, Sergio
no flags Details
File: var_log_messages (365 bytes, text/plain)
2012-12-06 12:52 EST, Sergio
no flags Details

  None (edit)
Description Sergio 2012-12-06 12:52:07 EST
Description of problem:
Had just reported a bug then clicked on 'Close' button but Firefox was opening at the same time so due to my PC being old/slow abrt's window didn't close immediately (after-all I think it had to move the bug report to the 'reported bugs' list) so I clicked on 'Close' again.
It closed, but immediately reported this crash ;-) (it was something in the background as the GUI behaved normally).

Additional info:
backtrace_rating: 4
cmdline:        report-gtk -e report_uReport -e analyze_CCpp -e collect_* -e report_Bugzilla -e post_report -- /var/spool/abrt/ccpp-2012-12-06-13:35:53-2967
crash_function: g_hash_table_remove_all_nodes
executable:     /usr/bin/report-gtk
kernel:         3.6.9-4.fc18.i686
package:        libreport-gtk-2.0.19-3.fc18
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 g_hash_table_remove_all_nodes at ghash.c:523
 #1 g_hash_table_remove_all at ghash.c:1345
 #2 g_hash_table_destroy at ghash.c:1049
 #3 assistant_quit_cb at wizard.c:3004
 #4 g_cclosure_marshal_VOID__VOIDv at gmarshal.c:115
 #5 _g_closure_invoke_va at gclosure.c:840
 #8 gtk_button_clicked at gtkbutton.c:1308
 #9 gtk_real_button_released at gtkbutton.c:1967
 #10 g_cclosure_marshal_VOID__VOIDv at gmarshal.c:115
 #11 g_type_class_meta_marshalv at gclosure.c:997
Comment 1 Sergio 2012-12-06 12:52:12 EST
Created attachment 658910 [details]
File: backtrace
Comment 2 Sergio 2012-12-06 12:52:14 EST
Created attachment 658911 [details]
File: cgroup
Comment 3 Sergio 2012-12-06 12:52:16 EST
Created attachment 658912 [details]
File: core_backtrace
Comment 4 Sergio 2012-12-06 12:52:19 EST
Created attachment 658913 [details]
File: dso_list
Comment 5 Sergio 2012-12-06 12:52:21 EST
Created attachment 658914 [details]
File: environ
Comment 6 Sergio 2012-12-06 12:52:23 EST
Created attachment 658915 [details]
File: limits
Comment 7 Sergio 2012-12-06 12:52:26 EST
Created attachment 658916 [details]
File: maps
Comment 8 Sergio 2012-12-06 12:52:28 EST
Created attachment 658917 [details]
File: open_fds
Comment 9 Sergio 2012-12-06 12:52:30 EST
Created attachment 658918 [details]
File: proc_pid_status
Comment 10 Sergio 2012-12-06 12:52:32 EST
Created attachment 658919 [details]
File: var_log_messages
Comment 11 Sergio 2012-12-06 12:55:23 EST
I *guess* was just because I clicked on 'Close' twice instead of waiting it to close the window.
Comment 12 Jakub Filak 2012-12-07 06:09:30 EST
Fixed in git

commit 0ececad341669ea8fc213c403581c4ddb7c8d203
Author: Jakub Filak <jfilak@redhat.com>
Date:   Fri Dec 7 11:49:06 2012 +0100

    report-gtk: destroy global text cache only once
    
    - closes rhbz#884791
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
Comment 13 Jakub Filak 2012-12-08 09:17:46 EST
*** Bug 855631 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2012-12-20 03:55:43 EST
abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
Comment 15 Fedora Update System 2012-12-20 04:46:05 EST
abrt-2.0.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc17
Comment 16 Fedora Update System 2012-12-20 20:30:30 EST
Package abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.20-1.fc18 btparser-0.24-1.fc18 libreport-2.0.20-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20725/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2013-01-11 20:16:59 EST
abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-02-25 21:39:04 EST
abrt-2.0.20-1.fc17, btparser-0.24-1.fc17, libreport-2.0.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.