Bug 885189 - ibus not working on Fedora 17 with XFCE 4.10
ibus not working on Fedora 17 with XFCE 4.10
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Other
unspecified Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-07 12:38 EST by manuel.uberti
Modified: 2012-12-10 19:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 19:34:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description manuel.uberti 2012-12-07 12:38:16 EST
Description of problem:
Can't input in Chinese pinyin without launch applications via command line with GTK_IM_MODULE=ibus. I have installed imsettings-xfce, as mentioned here: https://bugzilla.redhat.com/show_bug.cgi?id=496542


Version-Release number of selected component (if applicable):


How reproducible:
Using Fedora 17 with XFCE 4.10, install ibus and add ibus-daemon to startup applications.


Steps to Reproduce:
1. Open a text editor
2. Change input method using keyboard shortcut or by clicking on ibus icon in the top panel
3. Start typing
  
Actual results:
No Chinese characters, no panel to choose the right character


Expected results:
Chinese characters and panel to choose the character I'm typing

Additional info:
Comment 1 fujiwara 2012-12-10 05:27:21 EST
I cannot reproduce your problem.
Did you set ibus with 'im-chooser' command?
Did you install the latest ibus?

# yum install ibus
# rpm -q ibus
Comment 2 manuel.uberti 2012-12-10 05:52:27 EST
im-chooser did the trick. Do I have to add ibus-daemon at startup applications?
Comment 3 manuel.uberti 2012-12-10 06:03:47 EST
Ok, I did a restart of my PC with ibus-daemon still in startup applications and everything is working fine. I was missing that im-chooser command.

Thanks for you kind help.
Comment 4 fujiwara 2012-12-10 19:34:13 EST
It depends on the login locale in the first login when you created your account whether ibus runs or not by default.
And ibus won't run if the initial locale is en_US*
Otherwise you need to enable ibus with im-chooser in the desktops except for gnome-shell.
(gnome-shell uses gnome-control-center instead)

Note You need to log in before you can comment on or make changes to this bug.