Bug 88519 - Anaconda crashes on mouse select
Anaconda crashes on mouse select
Status: CLOSED DUPLICATE of bug 87431
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-10 12:56 EDT by Carlos
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos 2003-04-10 12:56:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When installing RH9 (language = portuguese) anaconda crashes 
when selecting the mouse. The mouse is a HP wheel mouse.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH9
2.Select portuguese keyboard
3.
    

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 764, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 985, in setScreen
    new_screen = apply(self.currentWindow.getScreen, args)
  File "/usr/lib/anaconda/iw/mouse_gui.py", line 232, in getScreen
    self.setupMice()
  File "/usr/lib/anaconda/iw/mouse_gui.py", line 122, in setupMice
    model = fields[1]
IndexError: list index out of range

Local variables in innermost frame:
parent: <GtkTreeIter at 0x849fc30>
toplevels: {'MM': <GtkTreeIter at 0x87ace20>, 'ASCII': <GtkTreeIter at
0x8260be0>, 'Kensington': <GtkTreeIter at 0x87db1e0>, 'Genius': <GtkTreeIter at
0x8818888>, 'Gen\xc3\xa9rico': <GtkTreeIter at 0x8426af0>, 'Logitech':
<GtkTreeIter at 0x849fc30>, 'Microsoft': <GtkTreeIter at 0x8763880>}
iter: <GtkTreeIter at 0x84dfe38>
key: Sun - Mouse
self: <mouse_gui.MouseWindow instance at 0x89af234>
fields: ['Rato da Sun']
make: Rato da Sun
model: MouseMan+/FirstMouse+ (PS/2)
value: ('sun', 'sun', 'sunmouse', 0, 'sun')
count: 1
Comment 1 Carlos 2003-04-11 11:39:13 EDT
Works fine when if english is chosen as langauage of instalation even if the
portuguese keyboard is selected.
Comment 2 Jeremy Katz 2003-04-11 12:16:34 EDT

*** This bug has been marked as a duplicate of 87431 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:52:36 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.