Bug 87431 - Norwegian / Icelandic / Portuguese install crashes with traceback
Norwegian / Icelandic / Portuguese install crashes with traceback
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
: 87864 88020 88102 88108 88128 88498 88519 88646 88717 89288 90088 91059 91078 96976 97090 97396 97602 97672 97798 98620 98694 98914 103839 104404 105958 106815 107783 108175 109236 110560 112500 113785 116519 117969 120619 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-26 16:11 EST by Inger Karin Haarbye
Modified: 2007-04-18 12:52 EDT (History)
39 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:56:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback from anaconda (42.84 KB, text/plain)
2003-03-26 16:12 EST, Inger Karin Haarbye
no flags Details
anaconda bug information (38.40 KB, text/plain)
2003-05-04 19:56 EDT, Nelson Reia
no flags Details

  None (edit)
Description Inger Karin Haarbye 2003-03-26 16:11:28 EST
Description of problem:
Red Hat 9.0 CD-install, Norwegian. CD's checked with mediacheck.
Traceback after keyboard is chosen.

Version-Release number of selected component (if applicable):


How reproducible:
Twice with Norwegian language/Norwegian keyboard.
English language/US keyboard seems to work.

Steps to Reproduce:
1. CD-install
2. Norwegian language
3. Norwegian (latin1) keyboard.
    
Actual results:
Traceback - attached
Comment 1 Inger Karin Haarbye 2003-03-26 16:12:26 EST
Created attachment 90733 [details]
traceback from anaconda
Comment 2 Richard Allen 2003-03-26 20:02:46 EST
Same for Icelandic, except I attemted to use the ISO images directly via NFS.

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 764, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 985, in setScreen
    new_screen = apply(self.currentWindow.getScreen, args)
  File "/usr/lib/anaconda/iw/mouse_gui.py", line 232, in getScreen
    self.setupMice()
  File "/usr/lib/anaconda/iw/mouse_gui.py", line 122, in setupMice
    model = fields[1]
IndexError: list index out of range

Full dump on http://www.ra.is/anacdump.txt
Comment 3 Pedro Miguel Marques Morais 2003-03-27 06:21:35 EST
Also happens with portuguese (pt)
Comment 4 Pedro Miguel Marques Morais 2003-03-27 08:50:25 EST
It's the language.I think I've found the cause of the problem.In rhpl you have a list of mice names that you can translate.Now, they are all in the form 'vendor - model'.Now, if your translation doesn't have the - you basically screwed and anacondawill crash. I did that just once, ironically in the last mouse of the list ('Sun - Mouse' -> 'Rato da Sun').Anaconda seems to be accessing an array that should have vendor on [0]and model on [1].If I print the contents of that array I only have ['Rato da Sun']For icelandic there are several problems of this kind:ALPS - GlidePoint (PS/2)ASCII - MieMouse (serialGeneric - 2 Button Mouse (serial)Generic - 3 Button Mouse (serial)Richard, please confirm this choosing debug after getting the tracebackand writing on the pdb promptprint fields
Comment 5 Richard Allen 2003-03-27 09:40:49 EST
I booted again and issued a "print fields" in the debugger.

"ATI bus mús"   no "-" in there.

I wasnt aware they where a must.   If I recall correctly, the mouse translations
in rhpl are just cut and past from mouseconfig.

Comment 6 Pedro Miguel Marques Morais 2003-03-27 10:06:01 EST
It seems they are an "undocumented must".But they aren't cut and paste from mouseconfig, in that (deprecated?) packagethe fields were separated (vendor and model in different strings).
Comment 8 Christian Rose 2003-03-28 09:35:26 EST
Cannot reproduce this with Swedish. But I suspect I kept the " - " in the
Swedish translation. In any case, things like this should be documented to
translators (or perhaps rather the vendor and model info split in seperate
messages rather than combining them in the same messages with an undocumented
seperator).
Comment 9 Pedro Miguel Marques Morais 2003-03-28 10:17:18 EST
Just checked, rhpl/sv.po has the separator on all mice. Lucky one :-)
Comment 10 Jeremy Katz 2003-03-30 14:58:34 EST
Update disk to not use the translated strings available at
http://people.redhat.com/~katzj/9-updates.img.  The screen is on my hitlist of
ones to change for the next release
Comment 11 Jeremy Katz 2003-04-04 14:39:29 EST
*** Bug 87864 has been marked as a duplicate of this bug. ***
Comment 12 Jeremy Katz 2003-04-04 15:23:54 EST
*** Bug 88020 has been marked as a duplicate of this bug. ***
Comment 13 Jeremy Katz 2003-04-07 14:32:20 EDT
*** Bug 88108 has been marked as a duplicate of this bug. ***
Comment 14 Jeremy Katz 2003-04-07 14:32:43 EDT
*** Bug 88102 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Katz 2003-04-07 14:43:10 EDT
*** Bug 88128 has been marked as a duplicate of this bug. ***
Comment 16 Jeremy Katz 2003-04-11 12:16:41 EDT
*** Bug 88519 has been marked as a duplicate of this bug. ***
Comment 17 Jeremy Katz 2003-04-11 12:18:56 EDT
*** Bug 88498 has been marked as a duplicate of this bug. ***
Comment 18 Jeremy Katz 2003-04-14 12:45:35 EDT
*** Bug 88646 has been marked as a duplicate of this bug. ***
Comment 19 Jeremy Katz 2003-04-14 17:29:16 EDT
*** Bug 88717 has been marked as a duplicate of this bug. ***
Comment 20 Jeremy Katz 2003-04-22 12:11:30 EDT
*** Bug 89288 has been marked as a duplicate of this bug. ***
Comment 21 Nelson Reia 2003-05-04 19:56:03 EDT
Created attachment 91495 [details]
anaconda bug information
Comment 22 Jeremy Katz 2003-05-05 12:05:14 EDT
*** Bug 90088 has been marked as a duplicate of this bug. ***
Comment 23 Jeremy Katz 2003-05-19 14:39:30 EDT
*** Bug 91059 has been marked as a duplicate of this bug. ***
Comment 24 Jeremy Katz 2003-05-19 15:20:22 EDT
*** Bug 91078 has been marked as a duplicate of this bug. ***
Comment 25 Brent Fox 2003-05-25 10:56:53 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.
Comment 26 Jeremy Katz 2003-06-10 18:33:02 EDT
*** Bug 96976 has been marked as a duplicate of this bug. ***
Comment 27 Jeremy Katz 2003-06-12 14:16:35 EDT
*** Bug 97090 has been marked as a duplicate of this bug. ***
Comment 28 Jeremy Katz 2003-06-18 12:26:42 EDT
*** Bug 97602 has been marked as a duplicate of this bug. ***
Comment 29 Michael Fulbright 2003-06-18 16:43:45 EDT
*** Bug 97396 has been marked as a duplicate of this bug. ***
Comment 30 Michael Fulbright 2003-06-19 14:34:07 EDT
*** Bug 97672 has been marked as a duplicate of this bug. ***
Comment 31 Michael Fulbright 2003-06-23 12:37:59 EDT
*** Bug 97798 has been marked as a duplicate of this bug. ***
Comment 32 Michael Fulbright 2003-07-11 11:42:49 EDT
*** Bug 98620 has been marked as a duplicate of this bug. ***
Comment 33 Michael Fulbright 2003-07-11 11:43:29 EDT
*** Bug 98914 has been marked as a duplicate of this bug. ***
Comment 34 Michael Fulbright 2003-07-14 12:36:45 EDT
*** Bug 98694 has been marked as a duplicate of this bug. ***
Comment 35 Michael Fulbright 2003-09-05 12:11:51 EDT
*** Bug 103839 has been marked as a duplicate of this bug. ***
Comment 36 Michael Fulbright 2003-09-15 15:22:53 EDT
*** Bug 104404 has been marked as a duplicate of this bug. ***
Comment 37 Jeremy Katz 2003-09-29 20:35:03 EDT
*** Bug 105958 has been marked as a duplicate of this bug. ***
Comment 38 Jeremy Katz 2003-10-23 10:59:37 EDT
*** Bug 107783 has been marked as a duplicate of this bug. ***
Comment 39 Jeremy Katz 2003-10-28 10:42:27 EST
*** Bug 108175 has been marked as a duplicate of this bug. ***
Comment 40 Sverre Olsen 2003-10-28 10:55:31 EST
remove me please!
Comment 41 Jeremy Katz 2003-11-14 16:37:29 EST
*** Bug 109236 has been marked as a duplicate of this bug. ***
Comment 42 Jeremy Katz 2003-11-21 16:24:55 EST
*** Bug 110560 has been marked as a duplicate of this bug. ***
Comment 43 Jeremy Katz 2003-12-21 12:20:27 EST
*** Bug 112500 has been marked as a duplicate of this bug. ***
Comment 44 Jeremy Katz 2004-01-22 12:05:34 EST
*** Bug 113785 has been marked as a duplicate of this bug. ***
Comment 45 Jeremy Katz 2004-02-23 12:05:52 EST
*** Bug 116519 has been marked as a duplicate of this bug. ***
Comment 46 Jeremy Katz 2004-03-10 12:36:00 EST
*** Bug 117969 has been marked as a duplicate of this bug. ***
Comment 47 Jeremy Katz 2004-04-12 23:58:06 EDT
*** Bug 120619 has been marked as a duplicate of this bug. ***
Comment 48 Miloslav Trmač 2004-09-28 20:21:51 EDT
*** Bug 106815 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.